Showing results for 
Search instead for 
Did you mean: 

"Sorry, we couldn't install [app name]. Visit Oculus Support to get help."

Heroic Explorer
This blows so hard right now! I've been getting the following message for over a week now when trying to install new apps: "Sorry, we couldn't install [app name]. Visit Oculus Support to get help." Then it started to freeze my computer upon opening Oculus Home. Finally decided to contact support, and since I refused to give them the log, due to privacy concerns (seems like a LOT of info that I have no idea what it really contains is being collected) and their solution was to reinstall the Oculus software. They sent me a guide what to nuke in Safe Mode. I did it, without even backup, just to make sure it's all clear. Unfortunately now nothing is installed and I still get the same damn message!  "Sorry, we couldn't install [app name]. Visit Oculus Support to get help." So not only I can't play ANYTHING, it looks like I will miss out on the Brass Tactics giveaway now too! I noticed that it does download the game, but it doesn't install it into Oculus Home. I tried to run exe and it says Entitlement Check Failed. I wouldn't be posting here if at least the support was faster with their answers, but each answer takes at least 24h+ and I assume they don't work on holidays. I don't know what to do at this point? Why wouldn't the damn software correct itself after full reinstall!?
Anyone ANY ideas?

EDIT: SteamVR games play fine, but are not being added to the library

So it 2019 and this problem is still happening to me.  I have the staging folder for all the updates but when installing it goes to 100% and then back to 0% and fails.

The way i fixed it was to delete the folder for the game in the Software folder, and then click install. It seems that the program has problems if it tries to overwrite that folder and its already there.

Not applicable
Avoid OS Folders e.g. Program Folders as is default! Better still to put Oculus plus Games on a 2nd Drive or Partition.
I spam this same thread every single day! @OculusSupport , @Techy111 just make it a STICKY please 😉

Heroic Explorer
I haven't uninstalled Oculus, but if I did and expected it to leave something POSSIBLY unwanted behind, would look to following places after the uninstall process;

Also check this post

Not applicable
Well a search for "Oculus" in the free Regscanner after deleting all seen/hidden files would leave loads behind!

Try this:
Make sure to go to these directories and delete the app/game's folder name within each: 
*C:\Games is wherever you have your default installation directory setup within the Oculus app.
Re-initiate the download (oculus app>library>updates>pending>click on the down-arrow next to the app name)

I also had this problem. I solved it by using the bandwidth limiter so it wouldn't use 100% of my Internet connection. Which is bullshit because other stores, from Steam to Origin to GOG to EGS don't have this problem. Not even Xbox.

Honored Guest
I'm selling my headset because of this issue, to many software problems with oculus and there support is no support. Go with a steam VR headset and be free from Facebook overlords.

This helped me w/ Population One! I looked everywhere and doing this solved my update and install issues. Thank you! 


Honored Guest

Same issue for about 4 months now just wanted to hop on today and forgot that ive been having this issue. i have a done a full wip of windows as well as install every redistributable i would need to install games and still nothin

Not applicable