cancel
Showing results for 
Search instead for 
Did you mean: 

removing devices from account

Pookiemonstr
Explorer

I have 2 devices on my account that I dont have anymore. How do I remove it? I already did factory reset, and returned the items. 

2 ACCEPTED SOLUTIONS

Accepted Solutions

NateDopp
Honored Guest

I finally got mine removed by going to https://secure.oculus.com and clicking devices on the left side of the page. from there, I hit delete device info. Removed the entire device listing from my account in one click and allowed me to enable app sharing on my new Quest 3.

View solution in original post

It worked for me by removing it from webportal like user NateDopp described. Than I just deleted all user data from Meta Quest app in Android app-settings, and after that I uninstalled and reinstalled Meta app. Now I only have 1 device shown in web and Android app. Dont know it works the same way for iOS though.

View solution in original post

44 REPLIES 44

MetaQuestSupport
Community Manager
Community Manager

Hey Pookiemonstr, totally understand your concern with not being able to remove devices to your account. They don't need to be on your account if you are no longer in possession of them and we want to help you resolve this. This is the proper way to do this. You go into your account on the Oculus website. Then there is a drop down menu where you can choose “My devices” and once on that page, you should see each of your devices listed.  You want to click the button underneath each device labeled “Delete device data”. If the issue still persists, please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Sorry, MetaQuestSupport, but that does not work if a person no longer owns the device. I've tried those steps several times, with different browsers, and keep getting an error message:

error message on Chrome.jpg

 

Please note that this is NOT a browser error -- your system is trying to wipe a device that "no longer exists" because I no longer own it. I factory wiped it before I traded it in at Best Buy to get a Quest 2.

The underlying problem here is that your system is trying to solve the wrong problem. The option is to "delete device data" -- on the device.  That's not what Pookiemonstr was trying to do, and it's not what I'm trying to do. I'm not trying to delete the information ON the device. I'm trying to remove the device from MY ACCOUNT.

If someone in Meta Quest Support could kindly provide a way for us to remove a device from our account, it would be greatly appreciated.

Hi, I'm having the same problem. I still have a device on my account that I sent back under warranty, and now I want to give my quest away.  Did you figure out how to delete the accounts? I'm getting the same message in red when I try deleting either one. Super frustrating. I'd appreciate a heads up! TIA!

Hiya @chemicaljones! We hate to hear that you are have a bit of trouble with removing your device from your account. So that you are aware, once a device is used on the account, it will stay there until registered to another account or until a certain period of time has passed. If you have any further questions or concerns, please don't hesitate to reach out to Meta Store Support. We would be more than happy to help you. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

viper6798
Honored Guest

I'm sorry but "until a certain period of time has passed" is just a poor response. What is the exact duration of "a certain period of time"?

I was told this 8 months ago when i retuned my first quest 2 for a screen tear. 8 months later and i still have this problem. It is highly annoying when trying to manage content and casting. Purely because your app chooses the original quest 2 by default for everything. You all can do much better than this and the horrible response given is no way to solve this problem. 

Hello, James! We noted that you said you had a tear in your screen, which upsets us because you can't play your games or see the screen as clearly as you should. Nevertheless, we have been in your position before, so don't worry; we can check into your problem further.

 

  1. Have you contacted support regarding an alternative headset?
  2. Would you please send us a screenshot of the screen rip?
If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hello, James_Casper! Please don't hesitate to contact us if you still require assistance with uninstalling your device while we check in on you. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

VRBruin
Honored Guest

Did you guys ever figure out how to remove devices from the Oculus/Meta app on iOS? The device still appears there but on the web portal it doesn't.  Why can't they just figure it out and let us remove the device from our accounts? Seems like some kind of spying.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?