cancel
Showing results for 
Search instead for 
Did you mean: 

stuck on horizon worlds wearable tutorial

kingluma
Level 2

I'm trying to use Horizon Worlds for the first time (on a Meta Quest) and I get a short animated overview/welcome presentation, I get the opportunity to edit my avatar, then the wearable tutorial starts and I am able to progress through the first 2 buttons (safety and camera ?) but then when it has me bring up the horizon menu (or the tutorial facsimile of it) it ends by telling me to tap the play button - and I do this but nothing happens in response and I'm stuck.... Rebooted and relaunched multiple times, today when I launched HW it notified me that there was an update so I updated but I still have the same problem - stuck at exactly the same place... PLEASE HELP, I can't listen to that intro/tutorial anymore and would like to actually enter Horizon Worlds - Thanks @kingluma

3 REPLIES 3

MetaQuestSupport
Community Manager
Community Manager

Hey @kingluma! That's terrible news that you're getting stuck in the tutorial of Horizon Worlds. We have a few troubleshooting step suggestions at this link. If those don't work you can feel free to send us a message back and we can see what else we can try with you!

I tried the process suggested at the "Stuck on the Horizon Worlds loading page" link you sent me and it didn't work. I wasn't so surprised since being stuck on the Horizon Worlds loading page isn't the symptom I reported. I get into Horizon Worlds and get past the check you r avatar bit then get stuck (meaning I am unable to advance) out of the Wearable tutorial bit - I find I must use my virtual finger (rather than the ray beam) to hit any buttons to proceed, but then it comes to a button - I am directed to "Tap the Play button to continue" and no matter which way I try to confirm with that button Horizon Worlds fails to acknowledge it and proceed. I've been stuck at this point (on and off as I've gotten a chance to perform troubleshooting steps) for DAYS. I've tried it multiple times (rebooting etc.). I've factory reset the Quest 2 headset I'm using, I've updated Horizon Worlds a couple times (when I saw updates were available - and I've tried what was suggested in the link included in the previous message of this thread. Other Quest apps I try seem to be working as expected as far as I can tell. Wow, who knew it would be so hard to even get into Horizon Worlds ?? I was invited into the Meta Horizons Creator Program and I'd really love to give it a try, but it's starting to test my patience just a bit. I await your next suggestion for how to resolve this problem. Thanks.

Hey @kingluma, we'll need to take a closer look into this issue. Please shoot us a message through PM so we can gather some information. Select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.