Showing results for 
Search instead for 
Did you mean: 

v46 frame drops/stutters/headroom dips


Edit: For anyone stopping by looking for a solution, there isn't going to be one. This issue is falling on deaf ears by meta staff. The issues described exist both in standalone and pcvr link/airlink. It seems to be widespread, possibly most or all quest 2 devices, yet it's been relayed that it's only a small subset of users experiencing the issue... sure. That's definitely why we can totally troubleshoot and fix it /s

The only remedy is going to be through an update issued by meta. I/You/We have done all the troubleshooting and bug hunting possible, all signs point to them. Good luck everyone!


Frame drops, reprojection (even with ASW set to Off), stuttering, performance degradation, and gpu headroom dipping to 0 or even negative has been since v44, and now v46 as well. I have come across this issue in many different posts here in the meta forums, elsewhere as well, and no one has come to any conclusions other than this HAS to be an issue with oculus software itself. Witnessing OVR errors and socket errors amongst others in the console logs and no previous fix is capable of providing any remedy to the current issue. I have tried all previous working drivers from nvidia, uninstalling with DDU and reinstalling old to new. No change. HAGS set to off, clean installed oculus based off of official support techniques (safe mode and manual folder deletion), toggled and focused console window, set high priority on ovrserverx64 and game running, disabled link sharpening, disabled mobile ASW, reset all graphic settings to default, set vsync to off in nvidia control panel, reset nvidia control panel, nothing. These issues stem directly from the oculus software and there's no chance of user error. For those hoping to chime in about windows update breaking the software, that is also untrue. I have now tried windows 10 on updates 20h1, 20h2, 21h1, 21h2, and 22h2 and this issue is present across all of them. I also tried on windows 11 builds 21h2 and 22h2 and the same issue persists. We desperately need a community update from @Ryanality as i know im not the first to raise this issue. I wish i could say it was just user error, machine setup etc. There are multiple internal errors displayed in the console window and i've submitted these logs with the support team as have the others experiencing this issue. It would be great if we could PLEASE get a public update regarding this issue. I have been troubleshooting this for several weeks straight.. i'm going absolutely mad. PLEASE HELP US!!!!!!!!!!!!!!!!!!!!!!! Basic troubleshooting, clean installs, NONE OF IT WORKS! 2 years of using this headset and software...and this is the worst its been by far! 😧

268 REPLIES 268

This is great news! Let's hope this leads to a fix for us soon.

For sure. Also have to remember that just because they say they have a fix coming in the next update doesn't mean it will fix it for everyone here all at once or at all. Very good news that they're addressing it though.

Expert Protege

This is continiuation of this thread.

In short some people may experience ocasional framedrops, it doesn't depend on hardware, or software installed on PC. 

Drops may happen everywhere, in random circumstances, Air link or Wired, Low or High res, 72hz or 120, doesn't depend on API or game as framedrops may occur even in Oulus Dash.


Example of the problem:

Example of dependance on settings :


As for now there is no fix, wanted to recreate this thread just so it would be noticed that problem which made appearance in v46, still present in v47, 

@Ryanality mentioned that there was "something" fixed about framedrops with 120 hz, but it appears that issue unrelated, as if you had drops with 90hz, it would still occur with 120hz, though if you only had troubles with 120hz install PTC worth to check, but this fix is unrelated.

At the moment Meta team should be aware 

Screenshot of support reply

Screenshot 2022-12-11 at 21-26-06 v46 frame drops_stutters_headroom dips.png

 Feel free to share if you having similar issue, preferably with your pc configuration.

@HomidWay Thank you for sharing such incredible information. You're much appreciated!

Kudos, kudos and more kudos!

While playing alyx, the intermittent cpu utilization of ovrserver and dwm.exe leads to stuttering of game frame rate. I wonder if other people have the same problem.

DWM huh? I'll look into it. As for OVRServer yes, if you'll pull up perfornace stats in Oculus Diagnostic Tool you might see that as frame drops your performance headroom goes negative with a sharp spike but to be honest didnt see this kind of drops since v46, but some for pople it did look exactly same.

Yeah I ended up buying a reverb g2 today since I'm mainly just sim racing. Trying to play on the Quest 2 just makes me feel sick now from all the juddering.

I'll keep the quest 2 for now in case meta actually fixes the issues but I'm not going to hold my breath.

Nvidia 3060ti

i7 12700k

64gb 3200 ram 

Ive had the same issue for some time now. I already went through support with the same issue, gave them my logs, used their "route this" app to test local network, tried all their suggestions, then tried an endless amount of other workarounds/fixes from reddit and others, and still zero solution! The frame drop/ stutter issue persists. Meta's Support team has gone completely silent on me. Ive followed all their advice, answered all their questions, provided all that they asked... and still no solution. No follow up, no apologies, nothing. If not for Virtual Desktop working well for pcvr, Id have returned the quest 2 where I bought it by now. Airlink is simply unusable for me. The tearing and frame drops go from annoying all the way up to migraine inducing. It worked ABSOLUTELY FINE up until one of the recent updates (v46?). All that said, good luck to you. A few seem to have resolved this issue one way or another, while others like myself have tried everything to no avail. 


Update 12-12-22 Issue still not resolved. Exhausted all support options, tried all their suggestions, also used their local network testing app ("route this"), and Meta support has now gone 100% silent on me. Another Meta version rolls out, yet same issue as before. What is going on over at Meta? How has this airlink frame drop issue not been fixed? They themselves claimed it was a known issue. Its been months!

I have the same issue since v46, still unfixed in v47. Meta replaced my headset, no change. Happens across different settings, OS reinstalls, different GPUs (AMD/Nvidia), and more. I've been trying for months to fix this, and nothing has made a dent.


Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?