Showing results for 
Search instead for 
Did you mean: 

AMD GPU & Oculus nightmare (nothing works anymore)


I posted the other day re AMD GPU drivers causing the Oculus software to just play up (see this change log )


Now I've rolled back the drivers to a previous one from the start of the year and link works again... for 5 to 10min, then quits. Anyone got any tips sorting this?


my system is AMD Ryzen 7 2700X and AMD RX 5700XT GPU






go to, download DDU and uninstall the AMD drivers completely.
Then setup again.


I had a similar problem with recent drivers for the RX 580. To solve it completely, I had to go all the way back to version 20.10.1.


In several succeeding drivers versions that came after that known-working driver, Oculus (Air) Link was reported by many to crash. For me, the headset would immediately show a message about Oculus Link app having stopped working. I didn't go through this when these drivers first came out. It was only after I had to go back to find drivers that worked that I found these apparent issues.


There is possibly some 21.x.x driver that works well, but I didn't have luck with many. At one point with recent drivers, everything was working order, but I updated in the past month or so, and I started to experience occasional driver timeouts that I thought were the result of summer heating up and VR taxing my system even if I was just viewing normal, lightweight programs on my desktop through Virtual Desktop. With 21.3.1 drivers, a known issue appeared: "Radeon RX 400 and 500 series graphics products may experience a TDR during extended periods of video playback". I think the issue is more complex than believed, and it persisted even when I had tried many recommended and optional driver versions between 20.11.1 and 21.6.2. Sometimes, I could barely start watching a video in Chrome, and using Oculus (Air) Link or Virtual Desktop on the Quest 2 had either instant or eventual driver timeouts. I think that sometimes there is no driver timeout, but the Oculus Link app will immediately stop working.


I don't think there is anything wrong with my card, and it wasn't overheating or something like that. It's fine on these old 20.10.1 drivers, but I guess it's possible that new drivers enable new features by default that a card of my caliber simply can't handle properly (unbeknownst to the AMD team). Your card isn't like mine, but I think you should suspect the drivers considering what I went through with some of their recent drivers.


so many would,could.

just read the release notes of the latest AMD drivers -> known issuses.
There are definteley some issues with oculus and AMD GPU drivers.

this seems to be working, rather than trusting AMD to remove the drivers. i'm now on 21.3.1

I've worked it out for me at least.


Kill Norton Antivirus.  .... Problem solved, I can airlink again and everything works.. FML

There are also many instances of "may" in the release notes. Excuse me, but I guessed I missed your point. I read the known issues and listed the one that applied to me. I am just sharing my experience because you have to go to a specific version of AMD drivers to find one that works.


The known issues are often based on user reports, and they don't always detail the extent of the issue. Sometimes, they don't get fixed before another issue that affects VR is introduced. This is a string of bad luck with AMD drivers released this year. However, the situation is just as messy when many people have to detail all the ways Oculus Link is known to be unreliable overall across many different hardware configurations. For example, many people will be stuck with the weak charging issue in all likelihood. Some people don't give up though and find a way to make things work no matter how many hoops they have to jump through.