Showing results for 
Search instead for 
Did you mean: 

Air Link with Unique/Specific Issues

Honored Guest

At one point in time, Air Link worked well with my quest and my computer. I had a laptop that was connected to a 5GZ WIFI router, and a quest 2 that was connected over the same WIFI. I had to disable the integrated graphics and enable it again each time I restarted my computer and wanted to play PCVR games, otherwise it wouldn't work properly. My computer was known to have issues in the past, so I wouldn't put it past it if that was the cause.

Now, whenever I would start up air link, over the same internet, same place, it would connect, but it would lag a lot to where it's unplayable. It didn't matter where I was within PCVR, it would lag. So, whenever I was able to hook up the computer to ethernet, I did. However, my quest couldn't even detect my computer over ethernet for some reason, quest is on the same network.

I would try using a Link Cable, but I've been having connection issues (I think it's another glitch, rather than just the cable, as I've tested it on other devices) and my computer has issues keeping the quest charged, and even drains the battery on the quest faster than it should.


Here is what I tried so far:

Restarting both devices

Repairing the Oculus app on my computer

Tried either Wifi or ethernet.

If I don't find a solution, I'm thinking of resetting my computer, as I wouldn't put it past the possibility that it is my computer.


What PC do I have?

Asus TUFbook A15.

CPU: Ryzen 7 4800H

GPU: Nvidia 1660-ti

RAM: 16GB 3200mHz

Storage: 512GB M.2 SSD


Thanks for your time! If you have any questions, feel free to ask.


Community Manager
Community Manager

Hey there, Raijin! Have you recently updated your laptop to Windows 11? If so we recommend rolling back the Windows 11 update and seeing if that alters anything with your air link connection. If you want to rollback the update and it's not been more than 10 days since you installed Windows 11, you can go to Settings>System>Recovery and choose “Go Back.” This will revert your computer to the Windows 10 version you had before installing Windows 11.; if that isn't possible try browsing through the community forums, fellow users might help you find an answer to the issue you're facing. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Honored Guest

Yes actually, however whenever I installed windows 11, it was working fine for a little while. It worked for a couple of weeks before doing this. Sadly, I can't go back to windows 10, as I have went more than 10 days in windows 11. I've reset my computer since then, and the issue still persists. I'm going to look through the forums again, but last time I checked it seemed that my issue was unique.