Showing results for 
Search instead for 
Did you mean: 

Awful audio stutter with Link all of a sudden. Caused by recent update?


(post & title were edited on March 15th after I discovered that this is an audio stutter issue not related to general performance issues)

About a couple of weeks ago I started getting really bad sound stutter when using Link with Quest (1 gen). By stutter I mean that for example the sound rapidly cuts in and out. Link is now unusable for me.

I don't understand what happened, because earlier this year everything was working fine and I have made no hardware changes. I had the Link bitrate set at 350 via the Debug tool because it made the visuals look a lot better (less blotches, banding etc). Above 350 I started to get stutter, which is understandable. But now even with the default bitrate it's stutter all the way. The stutter is clearly there even when looking at the Rift menu, so it's not app dependent.

Has anyone recently experienced the same? Could an Oculus update have caused this? I'm running app version I have tried restarting the Oculus service multiple times as well as restarting the computer. The problem is really unfortunately because I won't be able to spend hours troubleshooting something that was working fine before.

My CPU is an i7 8700 and my GPU an RTX 2070 Super. Until recently this was enough to keep things smooth.



I have the same issue. It is very easy to tell just by listening to the choppy, stuttering audio. You don't even have to be in a game, it is very apparent even in the link home environment. 


Quest 1 is unplayable via link all of the sudden. Quest 2 is playable, but the issue is still there. I've been using link for a year and have loved it so much. I've had no hardware changes.


@rocknrolz it indeed seems like we have the same problem. Any luck resolving it?

Since my original post I have narrowed down the issue to audio (not general stutter or performance). I was able to use Bluetooth headphones without stutter, so essentially I bypassed the Link audio completely. I guess another workaround would be to connect a pair of headphones to the PC with a long cable, but really, I think the Link audio should just work as intended.

I submitted a ticket to Oculus support last weekend but haven't heard back.

No I have not had any luck in resolving it. I have simply shelved the headset. I look through the responses on here daily, hoping one day I will see that the problem has been resolved. I have spent too much time trying to fix the issue.


I had an issue with my link cable start after v25.  Another post suggested - go to TaskManager/Details/Rightclick on OVRServer_x64.exe and set it to real-time.  This resolved my disconnect issue.  Your mileage may vary but I hope it helps you.

Rising Star

Yeah. The recent updates entirely ruined my hobby of playing fallout 4VR, which is pretty inconvenient a year into being unemployed in quarantine. It worked perfectly fine before V25 and I’ve changed absolutely nothing hardware wise. It’s honestly getting infuriating and I’ve just given up on the headset until I hear it’s been resolved. I’ve tried messing with the debut tool, I’ve even removed all my graphic mods, it’s just completely broken and it’s insane that reverting to an older version isn’t an option. 

Honored Guest

Having the same problem with my Oculus Quest on BeatSaber, and I can't take it anymore it is just so irritating and frustrating, it makes the game unbearable and basically unplayable. I've tried everything from absolutely clearing my whole system, buying their own branded $80 cable, factory resetting, and messing around in the DEBUG tools program. After researching any fixes at all it's unfortunate to say that they have had this problem for OVER a YEAR! with NO fix. I think I'm going to cut my losses and switch to another vr headset :(. In the mean while the oculus quest is benched to collect dust... 


@jesse.brophy I also read somewhere that changing the priority of OVRServer would help, but it didn't fix things for me. Someone suggested that opting out of Oculus's Beta program would eliminate stutter, but I wasn't enrolled in the program.

I just wanna be clear, though, that what I am experiencing relates to audio stutter, not general stuttering or performance issues. I edited the title of my original post to reflect this. There are probably many threads for discussing general performance issues.


Same, it's introduced by v25, not fixed for long time already. I am using the official Oculus Link cable with a USB 3.1 port running at 2.6Gbps. 

Hope Oculus can fix this in this year. There is a Oculus Link microphone problem, which was introduced on Oculus Link Beta in Nov 2019, not fixed until now, lol. 

Honored Guest

have the same problem since i bought the quest 2 with link - can only play native quest 2 games