cancel
Showing results for 
Search instead for 
Did you mean: 

Connection Quest 2 to pc, Enabling oculus link, loads then goes back to oculus device homepage

Chirp2705
Level 2

Hey Guys, sorry if you don't understand the title, but i need some desperate help.

My PC is VR Ready, and on multiple occasions I've been able to connect my oculus quest 2 to my pc via Oculus Link with no issues what so ever. However, lately I've been having real difficult connecting. The issue that I am having is when I press Enabling oculus link on the headset, it will do the loading dots for about 10 seconds before it just goes back to the oculus quest 2 home page. and even after trying to enable it again it will say Oculus link has crashed.
I've tried Restarting the quest 2 as well as my pc. That did not work. I've tried using different Cables. That did not work either, the main cable I use is the official usb c to usb c cable I got from the oculus store.

I have also had this issue in the past and unfortunately the only way I had found a way to solve this issue was to completely re-install windows on my PC. I do not want to do this again and would like to find a different solution, so please guys if you have any Idea of what i can do to fix please let me know. If you want to know my PC Specs here they are

 

System Manufacturer - Dell inc
Model - Inspiron 5676
Processor -  AMD Ryzen 7 2700X Eight-Core Processor
RAM - 16GB
GPU - AMD Radeon (TM) RX 580X

 

1 REPLY 1

MetaQuestSupport
Community Manager
Community Manager

Hi there, Chirp2705!

 

That definitely can be a hinderance when trying to enjoy your device to it's fullest capabilities. We appreciate your detailed post of troubleshooting steps you've taken. This helps us, help you even better! As this is going to take some advanced troubleshooting, we suggest submitting a ticket with our support team here: https://ocul.us/ContactSupport

 

We appreciate your patience and can't wait to get you back into the virtual world!