Showing results for 
Search instead for 
Did you mean: 

Could not install

Honored Guest
Hi looking for help getting up and running with a Samsung Galaxy VR with controller and a Samsung Galaxy S10 running Android 10. Setup went fine and Oculus installed no problems. I can use the headset to view the store and library but I cannot install most apps / games. I purchase (free apps) and they go to my library. When I click install, they download but then show "could not install [app title]". The only apps that have installed successfully are firetank, crazy tank and National Geographic. I've tried loads of others and they all fail with the same error. Any suggestions welcome please!

Heroic Explorer
Only simple suggestions like disconnecting wifi on both devices and reconnecting. Restarting both devices. Reinstalling Oculus app. And of course if all else fails factory reset. I had a unable to connect to wifi issue before and tried a bunch of things. Nothing would work. Did factory reset and it fixed it.