Showing results for 
Search instead for 
Did you mean: 

Got a new modem and router, air link not staying connected but the old 2 in 1 router worked fine.

Honored Guest

edit, got it working 1 time with this but then it stopped working after, keep getting cannot find your headset.


I read to go to your oculus app, disable the wifi then enable the wifi, do a factory restart, then try..


so I went to my app, saw the wifi wasn't connected through the app, even though the headset has my wifi and is connected. So I enter the password, connect to it and now air link is working great, then after the one time now it won't and keeps saying can't find your headset.


I went to network and sharing center > media streaming options and turned that on and now it is working...tried it twice in a row and worked. Tried it multiple times and it's having no issues, even went to 200 mb bit rate to stress test and no lag, I will up the dynamic bit rate later to test and see, but at least I am able to use air link now with this spectrum wave 2 router.



the original issues below



I got a new router from spectrum but it isn't working for some odd reason even though on the oculus browser I'm getting 200 dl speeds.


It's a modem + Router combo which I was told is better so I got it.


but my 4 year old 2 in 1 router+modem that could cause studders while watching movies across the house worked perfectly fine with air link, I even could be 25ft away in the bathroom and use air link to


lol, no idea why my arris 2 in 1 router, 4 years old worked fine but the docsis 3.1(good modem) and wave 2 wifi router(idk how good they are) wouldn't even let me stay connected to air link for more than 1-2 secs, giving me unable to find headset?


My old router can't be used on the new account but I tried it last night while it was still in service when the new setup didn't work and sure enough it worked.


The older 2 in 1 router worked with 2 fire sticks / 1 phone / my quest


My pc is connected with ethernet cable and I could stand 25+ feet away from my router while using #2 in the bathroom and be on my desktop with it.


I have no idea why it isn't working, like I said I did a speed test on the oculus browser and was getting a 200 dl speeds while ethernet on pc gets 230.

1 fire stick uses youtube / another for streaming movies / phone for messaging and facebook / quest 2 for whatever.


No way my old arris 2 in 1 router that was old as hell is better than ttis docsis 3.1 modem and the new wave 2 routers from spectrum, I was told in another thread to get a modem and router and to get the docsis 3.1 modem,

it's all in my room and about 3-5 ft away from me. I got a feeling the old settings is some how messing with something, the computer name says the same name. I've uninstalled my oculus pc app and factory reset my headset which sucked.


paired the headset to the pc then launched, sometimes I can see the desktop then it freezes and back to non airlink, then after it just sits with 3 dots for 5 seconds and back to non air link.


"We can't find your headset" message keeps appearing from the oculus pc app everytime I do it.



Honored Guest

I went to network and sharing center > media streaming options and turned that on and now it is working


i'll stress test it at 200 mb/s and then if that works i'll go to dynamic bit rate. I'm going to get a tp-link arch 1800x or whatever anyways to save on rental fee's, was just worried this was going to happen regardless. I hope nobody can access my pc files just because I turned that on.