Showing results for 
Search instead for 
Did you mean: 

Home, store, etc broken

Honored Guest
Just to add to the reports about this very specific issue

I've just set up a new quest and am unable to see Home (Oops, something went wrong. Try again later) and store (nothing to see here).

It is connected to wifi (5g) and the internet and I can connect to Google and Facebook via the browser, yet there is a message on the browser saying No internet. I have downloaded a free demo via the phone app and that has successfully transferred to the quest.

Have tried switching router, quest and phone off and on again and 2 factory resets. Have tried connecting using phone's wifi hotspot over 4g.


Honored Guest
Same here. Obviously a problem with newly setup Quests. I tried everything and noticed that my Quest actually IS connected to the internet becaus otherwise I could not browse youtube videos with the headset. Maybe some server problem? The app on my smartphone does not load properly either. So I guess it's not a problem with the hardware.

Community Manager
Community Manager
Hello @TommyTrinder we're aware of some issues right now, and working on getting them addressed for everyone. Rebooting the device should fix it, if it's not already resolved for you. If it persists, reach out here. - Principe
If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!