cancel
Showing results for 
Search instead for 
Did you mean: 

How Do I Get The Oculus Quest Cast Feature To Work With Chrome Cast Ultra?

Benman283
Level 2

Ok here we go…



I am having trouble with casting my headset to the TV. When I
first got the headset in August of 2019, I had a chrome cast 3gen. I managed to
cast my headset to the TV on a few occasions when I wanted to. I stopped
playing for a few months and have since returned.



I thought it would be as easy as before to cast but no..



Its like the feature has fallen of the face of this earth…



I cannot get the chrome cast to appear in the app or the
headset at all, not even a blink of hope.



My trouble shooting process:



·        
Make sure my phone, headset and Chromecast are
connected to the same 2.4GHz band Wi-Fi. – DID NOT WORK



·        
Make sure my phone, headset and Chromecast are
connected to the same 5GHz band Wi-Fi. – DID NOT WORK



·        
Factory reset the chrome cast. DID NOT WORK



·        
Uninstall the oculus app and reinstall it. DID
NOT WORK



·        
Use a Different phone. DID NOT WORK



·        
Make sure mobile data is off. DID NOT WORK



·        
Make sure Bluetooth is on. DID NOT WORK



·        
Disconnect oculus account from phone and
headset. DID NOT WORK



·        
Factory Reset Headset, uninstall app, factory
reset chrome cast. Set it all back up. DID NOT WORK



·        
Check router settings and make sure IPV4 was
running not IPV6. DID NOT WORK



·        
Make sure P2P connections are ok. DID NOT WORK



·        
Move the router closer. DID NOT WORK



·        
PURCHASE chrome cast ultra. Try both 2.4 and
5GHz bands again. DID NOT WORK



·        
Try ethernet with chrome cast ultra. DID NOT WORK



·        
REPLACEMENT HEADSET…… DID NOT WORK.



·        
Went to a friends house, with a different
network…. DID NOT WORK



Am I missing something here…… I physically challenge an
oculus quest developer to come to my house and try and make it cast on my TV…



NO I don’t want to cast to my phone! My family will not huddle
around a 5 inch screen.



The fact that this feature has been taken OUT of its beta
stage and is apparently a fully working tested feature is blowing my mind….



I will not be defeated by this and I WILL cast to my TV. And
No I’m not using a 2nd gen chrome cast! Yes I have tried turning it
on and off again! Unless customer support can provide me with something I haven’t
tried yet I don’t really want to read it.



Surely the software just does not work? I have tried more
than the average person could put up with and yet no luck.



I have attached some pictures of people with the same
problem.



Sorry but its got to the point of frustration.



Help from a dev would be great.



Ben Gszix7b5mjspv.pngou1jpz6o6hjk.png
18 REPLIES 18

MacGyver_VR
Level 2
Same problem here: previously worked without a hitch, for months.

As with the OP, I’ve reset and restarted everything I can think of: my previously-working Chromecast simply doesn’t even appear on the list of available devices any longer (on my phone or on the headset).

Not a huge show-stopper... and I’m incredibly impressed with everything that the Oculus team has been adding over the last few months. Just figured I’d add to the bug report list. 🙂

Spifff
Level 2
As another point of data i can add this. Old routers work just fine.

If i connect my quest to my old netgear N750 wifi (circa 2013) i CAN cast to my chromecast enabled tv.  
I setup another dlink router (2013ish) as an access point (Dhcp and firewall turned off) and if i connect the quest to it's wifi i CAN cast to the tv.
I setup a new  Dlink-867 (2018)  as an access point (dhcp and firewall turned off) and
if i connect the quest to it's wifi i CANNOT cast to the tv.  I have the symptoms as described above by the OP.  I just wanted the higher bandwidth wifi to help with casting.

My phone can cast to the TV when connected to the new DLink-867.  Just not the quest.

Crazy_Sane
Level 9
Hi,

That sounds pretty frustrating. But this is the community forum for users. Have you filled out a support ticket or chatted to customer support?

Benman283
Level 2
I can agree i am also really impressed with the new features! extremely! but it feels like they have taken away one of their best ones 😞 I will try to raise a support ticket now and post the updates.

cashxx
Level 4
Yea, I got my Oculus Quest before Thanksgiving in November and also bought a chromecast 3 to show it off to the family and it never worked.  That was when version 11 was came and people said it stopped working for them after version 11.  Still having issues with version 12 and 12.1 as well.  Was hoping to show it off more at Christmas time now and still not working.  Oculus is missing out on free advertising at this time of the year!

MEMPHISJOE
Level 2
I am having the same issue. It says in their troubleshooting to make sure it is on the same WiFi and all of that. Should be easy. I cant believe i have spent so much time on this. They need to fix it soon and it is a deal breaker. It says it will cast and it doesn't so fix it. Now. 

Spifff
Level 2
I have solved all of my problems just by noticing that is something to do with router settings.

I have a sony x900f chromecast enabled tv on wired ethernet.  On all routers it doesn't matter if i use 2.4Ghz or 5Ghz. i tested both in all cases.

if i setup my network using an old netgear N750 wifi (circa 2013) i CAN cast to my chromecast enabled tv. 
if i setup my network using an old dlink router (2013ish) i CAN cast to my chromecast enabled tv. 

if i setup my network using a new  Dlink-867 (2018)   i CANNOT see the tv as a castable target.
if i setup my network using a new Tp-link ARcher C7 (2018) I CAN cast my my chromecast enabled

I am now happy with the TP-link router. All my problems stemmed from something to do with the dlink-867 settings.   I assume it has soemthign to do with how the router handles multicast, IGMP, or ipv6.  Each router does it different and has different modifyable settings.  I could not find a way to make it work anywhere in the dlink settings.   Yet it works perfectly well in the default TP-link settings.

hope this helps others. 

cashxx
Level 4
I was told by support that there is a problem with IPv6.  But checked my parents router when I was home for Christmas and IPv6 is disabled by default so I have my doubts on it now.  Something is odd, but it only seem to be with the Oculus stuff for myself and my brother.  Can cast from anything else, but anything Oculus related it won't work.  I found on iOS I can broadcast from the headset to the phone fine, but no sound.   My brother has an android and won't work either way.  So Oculus has something messed up in using chromecast on their end some how.  I changed every setting I could find in my parents router and no luck messing with the settings.

ltejada32
Level 2
Hi!, any news on this topic?, still having the same problem...