Showing results for 
Search instead for 
Did you mean: 

Issues pairing Logitech K830 keyboard with Quest 2


Trying and failing to pair this keyboard. It works fine in USB mode (dongle attached via USB2 -> C converter -> headset), but connecting this way doesn't enable tracking for whatever reason. When I try to pair:

  1. Hit fn-del on keyboard, light flashes as it should
  2. In headset settings -> experimental -> pair -> pair new device
  3. Click on K830 to start pairing procedure, so far so good

At this point the screen resets/flashes, and I'll get a dialog box talking about hand tracking settings which need to be enabled. I see the keyboard tracking and I think I'm done -- but nope. 


When I click OK on this dialog box, the keyboard goes away, then I'm back in the bluetooth pairing screen. Error pops up "Can't open app", and it prompts me to turn on tracking. Which makes no sense, of course, as tracking was already on. I click turn on tracking anyway, and -- back in the pairing screen, and the K830 is not paired. This repeats with no change. Tried rebooting and resetting all experimental features.


Any ideas to get this thing working?


Not applicable

I too am getting this exact same loop of an error.


I found the fix!  You have to reset guardian from the guardian menu in settings.  After that, it will pair normally!

Honored Guest

I tried that and it still didn't work.  Does anyone have another fix action?

Honored Guest

Yep I'm too having the exactly same issue.

I fixed it 😊

Hi I just read another post, & I fixed mine.

I had the same issue as Halr9000 had.


But after I turned off the virtual Desk and restarted the headset, I saw the PIN window, I did have to do it twice as my hand tracking kept on clicking somewhere else and my cursor lost focus.

Then you can add the virtual desk.

Also I found after adding the virtual desk I really had to set the height a few times as my the k830 sank just under it and it looked like it was not there.