Showing results for 
Search instead for 
Did you mean: 

Link and SteamVR tracking stutter

Level 3

Hey everyone!

I'm wondering if someone had the same issue with the Quest2 and SteamVR as seen in this post (basically the behaviour as the right side of the video):


Oculus games work fine though after the fix found in that post. SteamVR is still jittery as hell.

I already tried stuff like putting the bitrate of airlink down to 10Mbps, using a link cable and also turning the resolution of games down completely. I reinstalled SteamVR and tried the beta version, completely removed my display drivers and did a clean install without GeForce Experience. Nothing seems to fix it.


My Rig:

i7 10700k

RTX 3070

32GB 3200 mhz RAM


Airlink can run around 150mbps with my 5ghz ac Wifi (It shows that numbers in the debugging console on my PC) and everything but this tracking issue runs smoothly.


I'd really appreciate any suggestions... These tracking stutters drive me insane 😧


Community Manager
Community Manager

Hi there! This can be very frustrating, and we are here to help the best we can. Let us work together to solve this issue.


Please follow these steps: 


Please disable Air Link on both the PC and the Quest 2

Restart Both the PC and the Quest 2

Reconnect both devices via the Air Link setup


I hope this helps, if it doesn't please submit a support ticket. 

Level 2

I have this exact same issue using link cable on PC, I've been trying to fix it for months. The tracking is absolutely perfect to a millimetre in oculus home, however as soon as I do anything in steamvr, which is where all my games are, the tracking becomes a complete nightmare. It just stutters and jitters constantly. My performance is also horribly stuttery as soon as I launch steamVR, even though my frametime is reading like 6-7ms and my target is 72hz. I have done absolutely everything in my power to fix this and I'm just totally out of ideas. Factory resettled both Quest and PC multiple times. 

Thanks for your answer, but do you actually think I did not try to restart it after everything I listed in my post? 😄

Exactly! I don't know why Oculus and Steam (Don't know which party is responsible) seem to don't care about that problem at all. I saw this issue coming up again and again for different people since 2 Years or so (Also on Rift Devices)