Showing results for 
Search instead for 
Did you mean: 

Link cable and air link, why so difficult to connect and use

Level 3

i recently had to re install my pc, and i am using the Oculus Quest 2 and am trying to get Air Link and link cable to work. I have had them working in the past, so i know link cable ect is ok, I have it on the PC App and the Quest. Whenever I connect to my PC, the Oculus app shows it has connected with all green ticks, but the Quest headset had 3 dots and then goes back to the home screen (normal Quest home screen) after i try to launch it..

I have the Asus Tuf A17 laptop with Ryzen 7 4800h and a gtx 1660ti dedicated gpu.

My laptop is connected to a powerline wired 5ghz connection from my BT smart router, (fibre, 70mbs speed)


Virtual destop works fine, so why is air link and link cable so difficult to use compared to vd.


I've tried the following with no success:

totally removed virtual desktop apps,
totally removed oculus pc app with an uninstaller program.
re installed oculus app.

Set all oculus software and games to use my nvidia gtx1660 ti in graphics settings. (so not to use internal gpu)

tried link cable, that will not connect either

-resetting experimental settings

- updating to the latest Nvida drivers

- disabling screen overlay in Geforce Experience

- uninstalling Geforce Experience

- disabling the Windows firewall

- reinstalling the Oculus PC app.


Level 13

Because your situation is not ideal.  A laptop with a 1660ti is the worst thing for air link/link you are not getting full 1660ti power.  Also laptops have this problem with oculus software using the IGPU and the dedicated GPU.  So you need to disable the IGPU in device manager and in the Nvidia control panel force oculus app to use the dedicated gpu.

Also for air link powerline adapters to run the ethernet to the router are generally a bad idea as they interfer with the signals that are required for link functionaility.

thankyou for replying, i have had airlink work before with this setup, and i have also had it work just of 5ghz wi fi, i can also have both ethernet and wi fi running together. When i first got the headset, link cable also worked, but after having a re install, neither work, yet show connected on pc app. I have made sure all oculus related software is set to use nvidia gpu, in graphics settings, also in 3d settings and in armoury crate asus software, disabling onboard gpu gives poor desktop resolutions and shouldn't be necessary

Level 13

Virtual desktop is mere emulation of the oculus app and it library not true native oculus usage.  You are missing out on a lot of greatness of oculus link/air link.

I have used air link/ link / vd for a lot of different case examples

vd i will use on pc:
1060 3 gb
8 gig ram

vd / link (depending on game) steam vr -vd  /oculus - link


2080 super

16 gig ram


air link (everything)


3080 ti

32 gig ram

wifi 6 router


I can pretty much test any configuration of pc specs

Level 3

ok, so i tried disabling on board graphics card in device manager, and to my surprise, air link worked. I thought i had everything to do with oculus app set to use nvidia gpu, so what did i miss, and how do i find a setting to be able to use both gpu's as normal.

So the managing software Armory crate from asus is kinda crap causes.  So the problem as of current is in reality a 1660ti is not adequate for quest 2.  When link was really in beta it was tuned down, but at the point the headset was only 72hz and they restricted the resolution scale.


See the link below for true recomendation to ensure flawless operation:

they are actually in process of redoing the requirements behind the scenes to make minimum a 2080 gpu

Level 3

so tried link cable, thats still not working, ran a game with airlink, to be honest vd worked better.


@Nosscar1956 wrote:

so tried link cable, thats still not working, ran a game with airlink, to be honest vd worked better.


Your still not listening vd is merely emulation and it can do somethings.  But link and air link will always be true native quest.  Your setup just isn't adequte for oculus native.

it does indead now state a gtx 2080 is required for some software to run properly, i think this was false advertising at the start, i bought my laptop soley because it was with stated vr requirements for quest 2, and was sold as vr ready.

so this is getting strange, i re enabled my onboard graphic card, and the air link is now still working, and in euro truck simulator it works fine with resolution per eye set to 2080 x2080. which actually looks better than in virtual desktop.