Showing results for 
Search instead for 
Did you mean: 

No 120hz option and no updated UI


I got my brand new OQ 2 first of last month (May 2021), and after setting it up, it updated automatically to v29. I never got to check out the experimental on v28 before it auto updated, so I'm not sure if any of those features were there. But it's now june 19th, running v29 and I still do not have the 120hz option in experimental, nor the newer UI. I DO in fact have airlink, the file manager, and the pass through. I have tried resetting my experimental settings, Tried disconnecting my link cable and robooting the quest, tried rebooting with airlink on, and off, tried rebooting with rift link on and off, and also tried a complete factory restore. All I end up with is what I currently have. So is it still completely random who gets the new features? Or is there something else I'm missing or not doing?


Community Manager
Community Manager

Hi there! Please click here to submit a ticket, we'd like to look further into this with you. Thanks!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I've submitted a ticket weeks ago, don't bother it's a waist of time.

Hi, I have had the same issue since 120hz support was released I'm v28.


All support advised was to wait for the missing features to appear, so I did patiently with no joy even with the latest update.


Both my sisters and mother have an oculus quest 2 all that live in the same town and they all have the features that I'm missing.


This made me then think possibly it's my headset, as all our settings were identical, oculus support said no it's a software issue just wait for the update to reach you properly. But I thought no, I have factory reset my headset multiple times, reset experimental features and changed language from English UK to English US but nothing made the missing features appear.


Today I received my replacement as I took it back to the store explained the situation and they sorted a replacement out... all missing features like the accessibility options and 120Hz has appeared.


Not saying this will work for everyone and hopefully you can get a replacement if still within warranty.


I have contact led oculus support to let them know of my resolution was a new headset so hopefully there maybe something they can do for others with the same issues. 


Hope this helps. Matt