Showing results for 
Search instead for 
Did you mean: 

No developer mode?

Level 2

I have an oculus quest and the new app just shows ‘advanced settings’ and no developer mode! Also I can’t get it to connect to sidequest. My oculus gives me a message to allow it but doesn’t connect I tried 2 different computers


Level 2

I have the same problem  but to be sure you verifyed your developer account with a cc or a phone number right? If you wound a way around that problem allready it would be nice if you say how


Community Manager
Community Manager

Hey there Ali.Bornstein, thanks for reaching out. We see you are having issues where you cannot see Dev mode in your Quest 2 settings. Usually this issue stems from not having a Developer account created yet. To create a Developer account, you must create an organization. This video here will show you how to create a developer account. This next link is to the Oculus Developer website so you can get started creating your account: here.


After creating your account, try enabling Dev mode in your mobile app settings, then restart your Quest 2 device and it should be there in your settings. 

I have the same problem. There is simply no button for dev mode showing up in the mobile app. 

I have followed all the steps to get developer mode enabled. Get a dev account. Create an organisation. Accept terms and conditions. Verify my account. 


Yet still no option for developer mode in the mobile app. 


(I also already had developer mode for about a year. It just disabled itself for some reason)

There is no developer button for me aswell I have tried everything i also had developer mode for 3 months and it disappeared for some reason 

Community Manager
Community Manager

Alright, thanks for that information. We have discussed this issue with our colleagues and it seems on October 21st, a change was made to the Dev accounts. Basically, those with a Developer account will need to access their Dev profile and add a valid Credit Card to their account. 


Here is the link to the developer website so you can log in and add that credit card. Hope this solves your issue!




I have no creditcards. I would be able to get a prepaid credit card from example Skrill or Neteller. Would this work? 


May I say that this Credit Card implementation has wasted me several hours. I've been working just fine for many months and then last Friday Adb suddenly stopped seeing the Quest. After hours of frustration, resetting Quest, re-installing Adb Drivers etc. etc. it suddenly starts working again after I see this thread and add a credit card to my account.

Very frustrating!

(And to think I initially blamed Windows 10 update)