Showing results for 
Search instead for 
Did you mean: 

Oculus Link - Graphic Driver Issue

Honored Guest

Oculus Quest 2


Never had this issue before, but today when I tried to connec to Oculus Link it's stuck in a loop with those 2-3 white dots. In the Oculus App on my PC it says "Graphic driver issue".

The only recent thing that I could think of that could cause this is installing Huawei's Hisuite. I deleted it, but the issue remained. The same issue is also with Air Link.

The only reason I suspect Hisuite to have caused an issue is because the PC seem to try to open VR headset like if it was my phone. I do click Deny on "Allow access to Data", but I have tried allow just incase as well.


I have the Oculus Link Cabel (5 Meter)


I have tried:

  • Clean install of newest Nvidia Driver (RTX 2080 Super)
  • Clean install of older Nvidia Driver I know worked before (August one)
  • Reinstall of Oculus App
  • Repair Oculus App
  • Factory Reset Oculus Headset

Any ideas?


Community Manager
Community Manager

Hey there khold93, we always want to make sure players can play the games they want. We'll do our absolute best to you back into the game again and get your Oculus experience up to 100%! Below I've outlined some troubleshooting steps you could try to ease any potential link issues.



Are there any updates to Windows/GPU/USB?


Sometimes there may be outdated drivers or pending updates that could interfere with the Link and its performance. I've included a guide on how to check for updates to your drivers here! The article is titled for Rift/Rift S but applies to Quest/Quest 2 as well.


For Windows, there's an article on how to check for updates here!


If updates are found for either, make sure you restart your PC once they are complete, then try to use Link again.



Game Mode may conflict with some VR applications.


In Windows 10, there is a feature called "Game Mode". Game Mode appears to reduce or eliminate background processes and focuses performance on the active game. This could interfere with the Oculus software, as it needs multiple processes running simultaneously to function properly. Try disabling Game Mode, then attempt using Link again.

  • Open the Windows Settings menu
  • Click on Gaming
  • Click Game Mode
  • Toggle Game Mode off


Submit a Support Ticket.


Collect Oculus Diagnostic Logs and submit them in a support ticket here so that we may look over them and confirm any conflicting software, PC/System updates and inconsistencies.



If you have any questions, we'd be happy to help! Cheers!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Honored Guest

Hey, thanks for quick reply.

I installed all the drivers I could find. I had tried Game Mode earlier actually as I saw in a post - sorry that I forgot to mention it.

I wrote to Oculus Support on twitter earlier, and I did get a reply now. He said Overwolf had caused issue for a lot of people, so I uninstalled it and now it works 🙂

Thanks a lot for helping me tho and sorry for wasting your time.

Hey there khold, we're happy to hear that your issue was resolved! Please reach out again if you have any other questions. Happy gaming! 🙂

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!