Showing results for 
Search instead for 
Did you mean: 

Oculus Link Logo Screen Freezes, Blinks, then...

Honored Guest

Hello, Ive run into an ongoing error with Oculus link.  Upon running from the Quest 2 home settings, the Oculus logo appears for a quick second, then freezes.  Then the screen blinks rapidly (kinda like it does in steam vr when loading a game), then presents a black room with a flat 2D gray screen with dark gray corners before me.  I've tried to revert to old AMD graphics drivers, as well as new ones.  I restarted oculus app, I even factory reset the Quest 2, with no luck.  I dont have the option to use VD or Airlink, because Airlink is virtually unplayable, and VD only works sometimes, intermittently turning the entire experience into a nauseating 2d flat screen, which increasingly becomes unplayable in a short period of time.  I don't know what else to try.  Haven't found any help on Google, or the oculua support center.  If anyone else has had this issue and found a fix, I'd like to know how you did it.  Thanks

Update:  After almost wiping my entire PC of data,files, and settings, using the internal Windows reinstall features,  I decided to Uninstall the Oculus app, then reinstall, and it Worked!  Link is back to its original, functional state.