Showing results for 
Search instead for 
Did you mean: 

Oculus Quest 2 very laggy in Steam VR VTOL VR game

Level 2

I am a very satisfied VTOL user since about one year, I play it using Oculus Quest 2 with USB cable. I played many missions, the game was always very fluid and responsive. Since few weeks, the game becomes very laggy, you can see it right from the start, simply by moving your hands; the movement is very jerky. I tried anyway to enter the game, but it is impossible even to start up the engines of a plane. I did not change any configuration, I just wondering what happened. Anyway, I noticed that the issue started after the last Oculus update, I don't really know if it can be the cause. Some notes:


  • In both Oculus Quest 2 and SteamVR, out of VTOL, the performances of other games are like before; movements are very fluid and responsive. The slowdown is in VTOL only
  • I already tried to change USB port, no success
  • The USB cable test is successful (2.7GBps – USB3)
  • I am running at the suggested resolution (72Hz – 3616 x 1840)
  • My PC: i7-10875H 2.30GHz – 32GB – HD SSD 2TB - NVIDIA GeForce RTX 2070 Super with Max-Q Design

Any suggestions are welcome!


Play safe! 🙂