Showing results for 
Search instead for 
Did you mean: 

Oculus link keeps crashing

Level 2

When I first got the Oculus Quest 2, I was able to use Oculus Link without any major difficulties, being able to play Beat Saber on it all the time. Lately, however, I have been having problems with the headset. At random times, it will go back to the Oculus Quest home whilst I am in the middle of a game. Sometimes it gives me the ability to relink and continue playing the game, but most of the time it crashes SteamVR and I have to reboot the game. 

I had generally thought that this was an issue caused by a new game I had gotten off of Steam, "Hotdogs, Horseshoes, and Hand Grenades" since Oculus Link had kept disconnecting once I had started playing that game. However, when I deleted the game to check if this was the case, Beat Saber still crashed, even more often than when I'd played the new game.

I then thought it might've been an issue with my graphics, and that I had turned them up too much for my computer and headset to handle. However, after resetting the graphic options, Beat Saber continued crashing.

I uninstalled and reinstalled everything I had, including SteamVR, Beat Saber, and the Oculus app on my PC, but the problem persisted.

I finally thought that it may have been caused by the mods I had installed for Beat Saber, but upon deleting those mods and playing the normal version, it would still crash.

I am guessing that this problem arose from a new Oculus update, but I would like to hear people's thoughts as to why this might be happening, and if anyone has suggestions to fix it.


Level 4

Same kind of things here.  I was on V26 update this morning and did a test of my Link speed which rang in at 2.5 Gbps on a 3rd party usb cable. After seeing some videos announcing a problem with V27 I put the Quest 2 on and it had updated to V27. I ran the test again and was seeing 1.7 Gbps for the same cable.  Link does kick me back to the quest also so that may be a speed issue now?  Steam VR games have problems when started from oculus or desktop while on the link (and Virtual Desktop) and I get error messages about Steam VR every game I try to run.  The visuals are also blurry (speed again?) and I had to quit after an eyestrain headache.

Level 2

Having the exact same issue only for me its not sometimes, it is literally every time I try to use any game that is off SteamVR. The most I have gotten a game to work was Blade and Sorcery but even that was unplayable with me being clipped into the ground, my controller was in the very center of my play area and pinned there no matter what I tried (Batteries being put in and out, trying both controllers, and multiple resets.) I have looked all over constantly for a solution to the problem I can understand since I have mental disabilities but have 0 leads from literally any source. I cannot play VR anymore due to the bug and have been through 2 cables, I still have yet to reinstall all my apps but from research I don't think that will make much of a difference. If ANYONE can help please let me know ASAP!