Showing results for 
Search instead for 
Did you mean: 

Oculus link keeps disconnecting


Hi I’ve just started having issues with my quest 2 it keeps disconnecting from the app and connects then disconnects and so on

ive tried a new cable another pc another headset ( my kids ) it happens on both pcs with different cables and different pcs is this because I have no internet at the moment ? 



When I mean the app I mean the oculus software on the pc to play games linked 

Honored Guest

Same thing is happening to me, every game. got my quest with V26 like 2 weeks ago. link cable reported 2.4gbps, no stutters over link, no crashes, occasional issues in the home environments but nothing inexcusable as far as my experience had shown, and battery stayed above 90% while gaming on link. V27 and link cable reports 1.1 or 1.2 gbps, doesnt last more than an hour before im kicked back to the quest home, loading stutters and freezes a lot, quest home and link home stutter and freeze often, and now the battery discharges well below 30% for the same play time. please can we get the option to roll back to the previous version till this is fixed?

Honored Guest

I have exactly the same problem. After upgrading to v27, the USB test shows a speed of 1.1 Gbps. Before the update, it was 2.3 Gbps. On the first day it was impossible to play. Disconnected every 2 min. On the second day, after a few disconnections, I played for 2 hours without any problems. Today it disconnects every 10 minutes. Very random. I only use the goggles via cable and the link is very important to me.

Mine disconnecting and connecting every second it doesn’t seem to know what it’s doing on both headsets and pcs 

I switched the beta tab off to go back to 26v but it’s made no difference 


Same thing happens to me. I reinstalled the PC app and factory reset my headset. I have tried multiple cables and USB ports but it keeps disconnecting every few minutes.

Expert Protege

Has anyone tried wireless? I don't use link at all but, seems like alot of problems since v26/27 showed up. Just curious. Haven't powered up in a few weeks.

Community Manager
Community Manager

Hey there, thanks for taking the time to troubleshoot this issue on your end! We'd like to look further into this with you to see what's going on, can you please click here to submit a ticket? Thanks!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!


Same, it's a common bug for v26/v27.

No way to fix, if still can return the device you can just return it.

If not, then go for virtual desktop instead of oculus link. 

Honored Guest

Quest 2 getting worse with latest updates, that means a new Quest is coming (which won't have these issues). I hope I am wrong. Because until now, it was just amazing stuff added that I wasn't expecting.