cancel
Showing results for 
Search instead for 
Did you mean: 

Official Link Cable not Charging Quest 2 at all from PC

HDMIPort
Level 2

Hey all, I just bought an official Oculus Link cable for 80 dollars expecting full functionality without any issues. Unfortunately, this has not been what I've experienced. I've noticed that even when both playing a game and not playing a game, both my front USB C 3.2 port isn't charging my Quest, same with the one on my motherboard. My motherboard is an Asus B550i Strix.

I've gone through all of the troubleshooting steps including disabling USB power saving, changing power states, and of course changing the ports.

Has anyone else with the official Link cable been able to charge their Quest 2 through their PC while using Link?

6 REPLIES 6

lensmandave
Level 9

Some motherboards don't supply sufficient current to charge the Quest via the link cable. The only way I could get it to work was to install a PCIe usb card with it's own dedicated power connection.

https://www.amazon.co.uk/gp/product/B087G7T234/ref=ppx_yo_dt_b_asin_title_o05_s00?ie=UTF8&psc=1

This keeps my Quest at 80% charge indefinitely.

Intel Core i7 6700K @ 4.5GHz. Asus-Z170-PRO MB - Nvidia RTX 3080 ti - 16GB DDR4 2666MHZ HYPERX SAVAGE.

TomCgcmfc
Level 15

@HDMIPort  I have a z390 mb with a usb3.1 gen2 type-c port and it keeps my Q2 headset with the official link cable reasonably charged.  I lose about 10-15% charge per hour which means I get at least 2x the runtime compared to the headset-only battery.  I have tried other sata powered pcie cards but these do not work much better imho.

 

The best alternative for me, with either standalone or Air Link, is to use an external 20000mahr battery pack, velcro strapped to my rear headstrap, with a short 1.5ft battery cable.  This gives me almost unlimited runtimes and nicely balanced my Q2 headset.

 

Also, if you need a type a-c adapter, not all of these work very well, nor do they supply power.  The only one I've found that works ok is the CableCreations one from Amazon.

https://www.amazon.com.au/gp/product/B074V4QBS4/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1

 

i9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, QPro w/Air Link, Vive Pro

Interesting. My USB-C Port charges my phone just fine but refuses to charge my Quest at all. It's not that it discharges it's that it doesn't charge at all. 

@HDMIPort  When you turn off your quest and the plug it in does a charge light turn on?  If not, maybe try flipping the connector 180deg and see if this makes any difference.  Could be a problem with your link cable?

i9 9900k, rtx3090, 32 Gb ram, 1tb ssd, 4tb hdd. xi hero wifi mb, 750w psu, QPro w/Air Link, Vive Pro

fezmonkey.solo
Level 4

All I know is that on my Asus PRIME Z270-A motherboard, the rear USB-C port would charge the Quest 2 just fine, using the official Oculus Link cable, at least enough to keep it from dropping charge while playing.

 

When I changed my motherboard to an Asus PRIME B560-Plus, the rear USB-C port with the same Oculus Link cable delivered no charge at all to the Quest 2. When I tried a different USB cable, an Anker USB-C to USB-A, it went back to being able to charge my Quest 2.

 

What's strange is the USB-C port on the B560-Plus can charge an iPad pro with the Oculus Link cable, but not the Quest. 

 

Finally, today I tried a USB-C to USB-A adapter, allowing me to plug in the Quest with the Oculus Link cable into my motherboard's USB-A port, that this seems to allow the Quest to charge once again, even while playing. I got this adapter: https://www.amazon.com/dp/B083XXLW77?psc=1&ref=ppx_yo2_dt_b_product_details

 

Note: not all adapters are created equal. I tried another brand of adapter which didn't transmit enough power to charge the Quest.

arcoli
Level 2

When you connect your headset to the pc, It prompts you to allow access to Data... you need to disable data access in order to the cable to work as a charge. This is the case for all USB ports.