Showing results for 
Search instead for 
Did you mean: 

Performance Issues with Virtual Desktop and Link

Level 3
I recently got my Quest 2 and it's been excellent as a standalone headset, but utterly unusable in conjunction with my PC. In both virtual desktop and using the link cable, I'm getting excessive latency, low framerates, and ugly compression artifacts, and nothing I've tried seems to have much effect.

I have a TP Link AX1500 wifi-6 modem set up as a dedicated wireless access point for the headset, and virtual desktop is showing a strong connection with 1200mbps bandwidth and latency around 23ms when streaming the desktop. My PC is running an RX5700XT, a Ryzen 5 2600, and 16gb of RAM.

As soon as I load into a game or the SteamVr home (yes, using VD's interface) my latency gets nuked to about 150ms and my framerate drops to the mid 20's to low 30's. Most of this isn't coming from network or decoding, about 80ms is from encoding and 40ms is from the game. This is with virtual desktop set to the lowest possible settings, 32mbps and low quality, and I've tried sliced encoding and all the other VD settings. Nothing helps. Lowering in-game settings doesn't have much effect. If I look on my PC, CPU and GPU usage levels are normal (50-80%, not low but not maxed either) and SteamVr's performance graph show middling GPU activity with good frame times and only minor spikes when loading a level or something similar. The only thing that has any positive effect is if I cut my render resolution all the way down to 20% in SteamVr settings. Performance with the link cable is also bad in all the same ways, and the problem persists on both connections when using Oculus desktop apps, so the issue may not be SteamVr either. I've heard that AMD's recent drivers have issues with the Quest 2, so I tried rolling back my drivers a couple times. So far, 20.11.2, 20.4.1, and 19.12.3 have all had the same issues. At this point, I'm at a total loss. I've seen people with similar or worse setups getting vastly better performance, so something is clearly broken. If anyone has worked through similar issues, or has any ideas for me to try, let me know. In the meantime, it's looking like the Quest 2 might not be replacing my old Odyssey+ any time soon...

Level 13
AMD Radeon RX 5700 XT

at 2k resolution per eye essentially 4k, there is absolutely no way it would do well.  so make sure render scale is at abut 1, if not .9 and then in game setting turn all the visuals down.

Level 3
I've tried knocking settings all the way down to minimum and performance is still barely acceptable, even with the resolution scale set to 20%. My Odyssey+ performed way better even when pushing more pixels at higher settings. I've been testing this on H3VR by the way, which his far from the most demanding game in my library.

Level 3
Update: I can get perfect performance with flatscreen games streamed through VD, but VR games are still unplayable regardless of settings/complexity. I tried Rez Infinite, the least demanding game in my library (it's a port of a PS1 game!) and still got <30fps and >100ms latency on absolute minimum settings and resolution. The majority of latency is still in encoding. If the issue isn't with drivers, what could possibly be going on?

Level 5
Check your CPU temperature with SpeedFan. If it gets to 90 - 100 degrees when you're playing then perhaps your cpu heatsink isn't seated properly or the cpu fan is malfunctioning. In this case windows will throttle down the performance.

Level 2
Have you tried changing th encode from 264 to Hevc? My 6900 XT is unplayable using 264, but HEVC works great.

Level 3
Update: upgraded to a Ryzen 7 2700X, no appreciable difference in in-headset performance. And yes, only HEVC is remotely useable for me, H264 is much worse.

Level 9
  Not sure it's related to your issue but yeah you should be getting awesome performance out of that. A few things come to mind. You have done some upgrading, be sure your PSU s up to the task of powering everything. If you haven't yet, I would install the AMD Ryzen master software and take a look at the voltages. 
 A issue I had with my original Quest was my duel band router was switching back and. I had to go to my router page and give each it's own login to lock it in 5g  
Gigabyte  AB350 Ryzen 2700x, 32gb ddr 4 3200, 2080ti. HP Reverb G2, Index controllers, Quest 1 and 2x Quest 2. 65" 3DTV HD3D DLP projector.

Level 2
i have the same issue

Level 7
quite possibly a driver issue.
AMD and nvidia RTX cards having known problems with link right now.
reverting back to an older driver works for both.
don't recall which driver but google should help with that
Antec Quattro ~ Asrock Taichi X399 ~ Threadripper 1920X ~ 32gb 3200mhz GSkill ~ RTX3060ti ~ m.2 970evo