cancel
Showing results for 
Search instead for 
Did you mean: 

Quest 2 Link: Black Screen (But Sound and Desktop mirror work)

Aussywoo
Level 3
I recently purchased the Quest 2 with the intention of utilizing both the standalone and PC functionalities. While the standalone version works with virtually no issue, Oculus Link has been driving my head through the ceiling and beyond.

My equipment:
HP Omen 15 Laptop (Ryzen 5 4600h, GTX 1660 Ti, 16gb RAM)
Oculus Quest 2
Included Charging Cable as a Link Cable (I am aware that it is a USB 2.0 connection -- I'm only testing at the moment)

Here's what's functioning:
Upon confirming that I want to run Oculus Link, the Oculus software does indeed open on my desktop. Checking in the devices section tells me that both controllers along with the headset are connected, though a USB 3.0 connection is recommended.

Here's what's not functioning:
The headset display itself doesn't display anything besides an occasional loading sign along with the guardian boundary warnings (since the charging cable only allows me to hover near my desk). I decided to open VRChat via the Oculus software to see what would happen. Opening the game doesn't display any errors. In fact, when I move my headset around, I can see my desktop version moving around along with the controllers. Sound does come through the Quest with no issues. The display continues its habit of showing the occasional loading sign.

I decided to try with the SteamVR version of VRChat. The results are a bit worse and confusing. In all scenarios, the VRChat client loads up frozen on the menu screen (though it is sometimes tilted as if my headset was tilted). The SteamVR window displays one of two things on any given occasion. The first, and most common, is where it shows the headset and two controllers connected, but has an error message above it stating there is a problem preventing it from working correctly. The second scenario simply shows no errors but still remains frozen.

Note: I opened both VRChat versions through my actual monitor.

Here's what I know:
  1. My laptop is capable and supports running VR
  2. Both my USB Type A and C are 3.0 and backwards compatible.
Here's what I've tried (in no particular order):
  • Restarting my PC
  • Restarting my Quest 2
  • Restarting the Software
  • Updating my graphics drivers
  • Using Nvidia Control Panel and setting Oculus Dash and other processes to use my dedicated graphics card
  • Trying a different cable (USB A to C through USB 2.0)
Here's what I have not tried, but plan to (in order):
  1. Reinstall the Oculus Software
  2. Reinstall my USB Drivers
  3. Factory reset my headset
  4. Buy an alternative Oculus Link Cable
  5. Give up
What I need help with:
Based on reading through other posts with similar issues, my guess is that there isn't just one known fix that should work. However, I would like some guidance on what to try or modify first. I just want to play Beatsaber.

Appreciate any help I can get!
Aus
0 REPLIES 0