Showing results for 
Search instead for 
Did you mean: 

Quest 2 Link suddenly only working Developer mode

Expert Protege
I have this weird issue with Link since today. First my Quest 2 wasn't recognized by my PC anymore. I always used it through a PCIe add-in USB 3 card, since it worked very well, I never tried the mainboard ports (ASrock z490 board). But then today when I connected link my PC would give me this message "usb device not recognized" and in Oculus software the Quest2 would not show up. So I tried the other USB 2, 3 and 3.2 ports on my mainboard, but it gave me the same error message. Device manager shows the Quest as "Oculus XRSP Interface", the German text reads "Device could not be started (code 10)":


Anyway I tried reinstalling USB drivers, deleted the quest 2 drivers and from oculus app - nothing worked. Before reinstalling I found a suggestion on reddit to try "developer mode". So I enabled it and low and behold, with it enabled (through the phone app) it works perfectly fine on all ports, add-in card and mainboard. But when I disable developer mode it stops being recognized and I have the same error as before.
I don't think this is normal behavior, any ideas how to fix it? And is there any downside to having developer mode enabled all the time?
I5-10600kf@5Ghz, 16GB DDR3600, RTX 2070

Honored Guest

Having same issue as this. Bumping thread to hopefully gain some traction