Showing results for 
Search instead for 
Did you mean: 

Quest 2 - Randomly crashes Oculus link app and really SLOW

Level 3



Not sure what to do anymore at this point. Not getting any support that works from OculusVR.

Had contact with oculus support but they are now suggesting to uninstall my graphic card drivers... WTF?


This happend:
1. Bought Quest 2 + link cable
2. Everything worked fine 120hz / high res / hl alyx steam

3. Link cable does connect but is so slow it crashes. Doesnt give a reason

4. Quest 2 getting slow.

5. Link cable only works with 72hz / low res / and no hl alyx steam

6. Link cable only sometimes works..


How is it posible that the Link app + Quest2 worked fine on 120hz for a month and after the V29 update it doesnt work anymore. Crashes all the time and its super slow.


I would say its the headset software/hardware.. But Oculus suggest i have to uninstall my rtx 3080 drivers :') That sounds like an awesome solution. thanks! whaha


So now im here.. sitting.. waiting for an solution. Tried everything i could find online. Nothing works.

Does anyone know what to do?


My specs:
RTX 3080
AMD 5900x
64 gb ram
Link cable 5m tested Oke in oculus app



Level 2

I have been having the same issue with my headset which causing my brand new computer to crash repeatedly. I have to force PC restart everytime it happens and my PV needs to be restarted about 10-15 times to POST properly. 

I have almost identical specs to you, but have an Intel CPU. I have a Nvidia 3080. 


Here is what I have tried so far:



-I have disabled my firewall completely, I have also selected every single .exe file in the Oculus folder and allowed them individually through the firewall. This had no success.

-I reinstalled Microsoft Windows back to factory, tried a bare bones system and had no success.

-I reinstalled and updated every driver, video driver, chipset driver, wifi and network driver, still no success.

-I have tried every different power setting and combination with no success.

-I have tried every different version of the drivers suggested and still no success.

-I tried disabling the Oculus Audio device completely as one of the errors in the attached log file was Oculus audio device related. This gave no success.

-I haven't used Virtual desktop since the reinstall of windows, this has had no success.

-I have factory reset the Oculus device and had no success.

-I have disable hardware acceleration in both my web browsers, still no success.

-I have tried to configure my router for the Traffic running through the network still had no success.


Oculus support have now asked me for my serial number and headset info and  have stopped offering any suggestions. I am a bit worried that they will blame Nvidia or Dell and say to work with them.


I'm not happy and not confident that I'll get it worked out. 

 I've got the same issue, and it's 100% not related to the gpu. I tried to run it on both my 3080 (laptop) and my integrated gpu (which also worked prior to the update) but to no avail. I just get the three dkts, then it crashes...