Showing results for 
Search instead for 
Did you mean: 

Quest 2 stuck to 72 hz after oculus software update tonight


Oculus software updated and now even after changing the frequency to 80 or 90 hz it is stuck to 72 hz in games. I have tried to reboot the device, change cable, reboot system....nothing works, it still stuck to 72 hz. With Virtual Desktop wireless it works fine at 90 hz.


Can you try with the file downloaded from this web? This is the one that worked for me to install V26.

I've tried repairing, installing, reinstalling. Nothing helped.


Same issue! 


How did this update get into production? Is there no testing?

Honored Guest

I have the same issue! Also my Quest 2 no longer charges via link and drops battery at almost double the rate! Connection test used to give me 2.2gbps now I am only getting 800mbps! Seriously fix this now! Its was working 100% fine since november but now its just useless! I only use my Quest 2 for pcvr and am thinking of selling it and getting a HP Reverb G2


This is frustrating. Really. The issue has been widely discussed when the software was in Beta. I don't believe the devs could not have seen it.

I hope we see at least some communication from them in the meantime.

For now - I'll be trying to downgrade to 26

Sadly I have just tried to roll back and it did not work 😞 Hopefully you have better luck?

Did not work for me either - despite blocking the updates, it has downloaded v27 from the v26 installer.

Submitted a ticket...

Honored Guest

I also rollback from v27 to v26 on my pc app to no avail.. steam vr through link is still stuck at 72hz. My headset software is still stuck at v27 so I’m not sure if that is an issue. Also created a support ticket.

Yeah, but it will automatically update to the latest (27) within a short amount of time.


I've solved this issue by rolling back to v25 (you can download v25 from this post on reddit) :
and you have to follow the instructions posted on the top comment to prevent the app from updating to v27 again