Showing results for 
Search instead for 
Did you mean: 

Quest 2 won't run MSFS 2020 or anything a bit heavy anymore. Is my Quest 2 defective?


Bought my first Quest 2 about 2 weeks ago for standalone Oculus games for my daughter & flight sim VR for me. At first the headset was not totally reliable with the official Oculus link cable. But would run MSFS ok (Microsoft game pass version). Steam VR was hit or miss. But using Air link MSFS would run fantastic. But as of a few days ago whilst I can link the PC with air link or cable and use virtual desktop all day long to watch videos or whatever as soon as I try MSFS for example the link drops out. If I have virtual destop on and have the oculus app as the active window & MSFS in the background it's happy enough. But the second I make MSFS the active window I lose link in cable or air. Trying to reconnect just ends up with the 3 dots showing and then crashes back out to non linked home screen everytime. On steamVR trying to run IL-2 (on cable only as won't work at all for IL-2 on air link although it will run "The lab" fine on air link) just result's in constant reconnection to the point it's unplayable as only last's about 5 seconds before the black borders start showing. Since it stopped working altogether I've updated my GPU & CPU drivers. Done my USB drivers so they are up to date, double checked my OpenXR driver was ok, reduced graphic settings, tried multiple cables (actually a £7.99 Juice cable gave the longest trouble free flying for 2hrs but even that doesnt work now), tried every single USB 3/3.1 & even 2.0 port on the PC. Im totally stumped now. I don't want to keep hold of £300 (plus £80 of cable) of device that doesn't do what I need just so my daughter can play "Job simulator" every sunday. Any pointers before I send this thing back?

AMD Ryzen 7 2700x 8 core 3.70ghz

32GB ram

Windows 10 64bit

Nvidia 2060 super.

Asus MB

Cheers in advance.


Expert Trustee

Not sure, but it might be that Microsoft Flight Simulator is too demanding for Air Link. Which if so, is understandable. That is a very demanding bit of software to begin with.

Lo, a quest! I seek the threads of my future in the seeds of the past.


It used to work on cable for me too but now its a piece of ****. Oculus link is broken and for me steam does not work either

Thing is it was working perfectly last week on air link. Now it doesnt work on either air link or cable? Don't know what's changed. 😞

Sounds like we are having the same issue. It's frustrating as it was perfect last week now it's just 2 hours shouting at the PC/Oculus instead of flying.

Honored Guest

I use Virtual Desktop with my Quest 2 and MSFS ... works very well.  Screw cables.

Not applicable

My Quest 2 worked perfectly approx. a week ago but now wont run MSFS at all it just crashes to Quest home. I'm not sure what's changed but something has,

Not applicable

make that 3!!!


Honored Guest

Same here. It was working just fine and then nothing. WTH?