Showing results for 
Search instead for 
Did you mean: 


Level 4

I've been trying to install a game called SAIL from App Lab.  It shows up in the headset under the "Uninstalled" section.  I click it to install and it starts downloading.  When it gets close to the size it needs to download it switches to "installing" then just stops like anything ever happened.  I click the install again and it does the same thing.   I've rebooted and/or shut the headset down.  No joy.  I've searched the headset SideQuest and Windows Explorer for any files related to the install and find nothing,   The path is as follows:  com.g119.SAIL  


Found the APK on and tried to install it through SideQuest and Oculus didn't like that.  The game used to be installable via SideQuest before it moved to App Lab.


It's pretty frustrating as I have installed many games since this started.  So far it's just this game.  Thoughts?


Community Manager
Community Manager

Hey there @DASFREAK, this isn't what we like to hear! If you are still not able to install the game after a few attempts, please ensure that you are connecting to a strong, stable WIFI network and not a hotspot. Please also ensure that the software on your Quest 2 is up to date and reboot the headset to ensure all software is being loaded correctly. To install any available updates you can leave the headset plugged in and connected to Wi-Fi for at least 2 hours.

For this issue, you can also try connecting to a different WIFI network in another location. To help us look into this further for you please reach out to our support team here. Cheers!

I have tried it on 2 dedicated WiFi networks on both 2.4 and 5 GHz.  My headset is on V32 and I have installed other games since I've tried installing this one with no issues.  Also as I stated I have shut down and/or rebooted numerous times with no success.

Hey there! We definitely understand. If you haven't already, please submit a support ticket with us here, that way we can help you in getting to the bottom of this! Please also make sure to include your Oculus Logs so we can look into those as well! Cheers!

Where do I access the logs so I can provide them?

Hey there @DASFREAK! We have a handy support article detailing how to attach logs to your support ticket here!

If you have any questions or concerns, feel free to reach out! Cheers!