cancel
Showing results for 
Search instead for 
Did you mean: 

Star Trek Bridge

TheSlasher07
Level 2
Just got Star Trek Bridge for my Quest.  I have my Ubisoft account open on both desktop & mobile and my Ocukus account open on both desktop and mobile but I can't activate the game o my Quest?  It asks me to setup or open my account but my controllers will not become visible to select "open account". Help!!
6 REPLIES 6

DaftnDirect
Volunteer Moderator
Volunteer Moderator
Hi @TheSlasher07
I have the Rift but not the Quest version of the game and that Ubisoft account thing seems to be a problem for a number of Quest users having read through the Quest version's game reviews. I've tried to summarise the steps that Ubisoft say should be followed and the things users have reported as solving the problem, hopefully this helps...

Ubisoft's instructions:
     If you have Uplay open on your desktop, close it.
     Open mobile Oculus app and enter the redeem code (Settings, Redeem code, Install now)
     Put on headset, and go to Not Installed games (Navigate, library, Not Installed)
     Install game
     Start game and login to Uplay
     After login, the game should prompt you to close
     After closing, the accounts should be linked
     You should see the game in both your Oculus and Uplay libraries.

It looks like people follow the instructions but still have problems linking accounts, so other things that seem to help are:
     Create a Uplay account first via PC before doing any of the above including verifying the account via email.
     If using a mobile browser to create a Uplay account, use desktop mode (apparently this makes a difference).
     After logging in within the headset, with the page still showing, restart the Quest.
     If accounts seem to be linked but game doesn't recognise link, logging out and then back in to your Oculus account via the VR browser can trigger the game to recognise the link.

Intel 5820K OC@4Ghz, Titan X (Maxwell), 32GB Corsair Vengeance DDR4, ASRock X99 Taichi, Samsung 500Gb 960 Evo M.2, Corsair H100i v2 Cooler, Inateck KTU3FR-4P USB 3 card, Windows 10 Pro v21H2 (19044.2075)

wuzp
Level 8
The UbiSoft responses to Quest store reviews, look like a bot wrote them; because the answer always ends up with a URL that points to a "Rift  applicable" solution.  The Quest anniversary sale on Bridge Crew happened the same weekend as the version 17 rollout; so I'm not sure how much of the problems I encountered were because of the rollout or because of the game itself.  In any case, I ended up doing an auto-refund.

If Oculus is supposed to be a consumer gaming platform; it should be consumer friendly.  You don't see these kinds of issues with Sony or Xbox systems.

TheSlasher07
Level 2
@DaftnDirect thank you very much for this.  I found most of this as well and went through the steps but still no luck.  Looks like I may just auto refund this game.  The game has installed and is visible just won't allow me to enter.

DaftnDirect
Volunteer Moderator
Volunteer Moderator
That's a shame @TheSlasher07 I've no idea why some people link the accounts ok and some don't, I wish Ubisoft would look into this a bit more because their procedure clearly isn't working for everyone.

@wuzp I agree, the Quest even more than the Rift-S needs to be user friendly as it's aimed at non-PC users. I think the problem is that VR in general doesn't have the users that put it in a position to dictate to developers that multiple account creation and linking (for example) is to be avoided.

Ubisoft for their part obviously want to use the title to gain Uplay accounts in order to promote their other games and that must have been a factor in deciding to expend resource on a VR title. Likewise Oculus aren't really in a position to reject such a big-name title because of this issue alone. Also, because VR is small compared with xbox and PlayStation (and pancake PC), developer resource is going to be relatively scaled back in comparison unless there are sufficient people involved within those companies who are enthusiastic about the tech to allocate the numbers to it rather than to more lucrative pancake or console work.

I think VR still has a fair bit of maturing to do and that should speed up as user numbers increase. But if anyone from Ubisoft reads this, please look into it and don't just issue the same instructions to everyone.

Intel 5820K OC@4Ghz, Titan X (Maxwell), 32GB Corsair Vengeance DDR4, ASRock X99 Taichi, Samsung 500Gb 960 Evo M.2, Corsair H100i v2 Cooler, Inateck KTU3FR-4P USB 3 card, Windows 10 Pro v21H2 (19044.2075)

MyDogChumley
Level 2
Are there any updates on this?  I have been having the same issue with this game and am getting quite frustrated with the lack of progress in getting the log in issue resolved.

Knerdy
Level 3
This fixed it for me... I went into my UbiSoft account information and I linked my Facebook account. Then I was able to link the accounts on my Quest.