Showing results for 
Search instead for 
Did you mean: 

SteamVR fail after update

Level 8

Hello all,

I have several hundred hours of use over link on my Quest 2 and immediately after getting the update today I can't get it to work.  I've already gone down the "can I just revert to the older patch" rabbit hole when they've rendered link useless during other updates, and I'm not interested in any manual installs/workarounds.  Every time I try to fire up a game in SteamVR I get sent back to the link desktop (where you can see your recently played games on the left, library, settings, etc on the bottom) and SteamVR shows me (on my monitor)--


"SteamVR Fail"

Steam VR has encountered an unexpected problem.  Please visit SteamVR Support for more info".


I will list my specs below, but since I have hundreds of hours in a few games, and I'm not trying anything new, it hardly seems important.  Unfortunately it IS a laptop, but..again, it's been more than cutting it for a year and a half now.  


I've tried uninstalling/reinstalling everything, public test channel/no public test channel, beta/no beta.  



Intel(R) Core(TM) i9-9980HK CPU @ 2.40GHz 2.40 GHz

32 Ram



Level 2

I had something similar happen to me, have you tried launching games from the PC instead of initiating from the Quest?, I had to do that after an update I think. In the end out of frustration I bought Desktop VR and now use that to connect to the desktop from the headset and launch all my PC based games from there, works very well. Good Luck!

Level 8

I tried initiating from the Quest and from the PC (restarts of everything involved betweem) with no luck.  I do not have Desktop VR. I'd be open to trying if it reliably seemed like it would solve it. 

What do the Windows event logs say about the crash?. 

Level 8

Hey Liam,

It worked right away for me explanation.  I didn't want to disappear and not clarify that.  Steam itself was down for a short bit the other night, which I've never seen before, so maybe it was just a steam error. 


Thanks for your efforts.


PS: I don't even know how to check my windows even logs.  To clarify, it wasn't starting up then crashing, SteamVR was refusing to launch to begin with.  Sorry for the gap in my tech knowledge here.

Interesting, I had no such problems, and SteamVR has worked flawlessly the last years, I really don't recall any issues. But I only use the Valve Index for SteamVR, unless a game supports native Oculus drivers - then I may use the Rift CV1. Also the CV1 has worked flawlessly with Steam for as long as I can remember. Thus problems may be related to specific hmds and drivers. 2c. 

Valve Index & Oculus Rift CV1, Asus Strix OC RTX™ 3090, i9-10900K (5.3Ghz), 32GB 3200MHz, 8TB
"Ask not what VR can do for you, but what you can do for VR"