Showing results for 
Search instead for 
Did you mean: 

SteamVR not showing up in Oculus Link library.

Not applicable

So, I'm hitting a brick wall here. Got a cable to run Link, got Oculus software installed, got Steam and SteamVR installed, hooked up my Quest 2, denied accessing data, allowed it to use Link, aaaannnnnddddd......


Only thing showing in my library is the Tutorial that comes pre-loaded. Every single other video I've watched SEEMS to say it should just be there when I look in library.


Does anyone have any suggestions on what to try? I'd rather not spend any more money to try to get this to work, if possible.


Try enabling Link so that your Quest displays the Rift Storefront, then click the button at the bottom of the screen to display your PC desktop. Run your SteamVR applications from that desktop view.


@Anonymous  Don't know but when I went to enable Link I did not deny accessing data.  Also make sure your Quest settings experimental have Air Link disabled.  With your Oculus desktop app make sure that settings/general tab has alternative sources enabled.


I'm sure there are a lot of ways to go into and out of steamvr but the best way I've found that works great for me is to allow Steam to startup when I startup my PC.  This is in your steam settings menu.  This goes to my taskbar (lower right).  After I start up Link I call up the oculus virtual desktop, then go to the lower right taskbar and click on steam, the select steamvr.  This opens up steamvr and I end up in the Steamvr void.  The library app panel menu normally shows up after a few seconds or I can click the left controller menu button to make it appear (and re-centre).  Then I just select whatever steamvr app I want to.  After playing I click the controller left controller button an select close the app.  I can then select another app of if I want to exit steamvr I just click the right controller oculus button and choose to exit SteamVR.  All works perfectly for me with my Q2 using Link.  Hope this helps.

i9 13900K water cooled, RTX4090, Z790 MB w/wifi6e, 32Gb 6400 ram, 2x2TB SSD, 1000W PSU, Win 11, QPro, Q3, w/Link and Air Link, Vive Pro1 with Etsy lens mod and Index Controllers


The Oculus software doesn't know about Steam. It won't automatically show SteamVR or Steam games. You have to run the games at least once for the Oculus software to become aware of them.

Go into Steam and run one of the games. It (and only that one) should get added to the Oculus library.


You'll also need to go into the settings of the Oculus PC software, go to General, and turn on Unknown Sources. This setting lets you run games that weren't bought on the Oculus store.

Author: Oculus Monitor,  Auto Oculus Touch,  Forum Dark Mode, Phantom Touch Remover,  X-Plane Fixer
Hardware: Threadripper 1950x, MSI Gaming Trio 2080TI, Asrock X399 Taich
Headsets: Wrap 1200VR, DK1, DK2, CV1, Rift-S, GearVR, Go, Quest, Quest 2, Reverb G2

Not applicable

Hrm, I tried that, it didn't seem to work.

I didn't get the Void, and on the status bar that showed up, it said to "Put on Headset to wake up", and I tried putting my Vive headset on briefly to wake it up, didn't work.

Not applicable

I have Unknow Sources turned on, and I tried to run Beat Saber, it just showed up in the VR Desktop window, and wouldn't let me interact with it.

Hello there!


We see that you are experiencing an issue with accessing SteamVR games on your Quest 2 while it is tethered to your PC via the Oculus Link cable. Please try the following troubleshooting steps below, as they may help with resolving this issue:

  • Make sure that you have downloaded Steam and installed SteamVR.
  • Check that your Oculus app is updated and that it allows you to play PC VR games on your headset.
  • Allow access of all files to be shared between the Oculus device and PC.
  • Disable any Antivirus or Firewall software that could be preventing the SteamVR games or software from running.
  • Try restarting your PC and Oculus device.

You should be able to start the SteamVR shortcut from the Virtual Desktop application menu. If you are still experiencing an issue with opening SteamVR from your Quest 2, please let us know by sending us a Private Message or by submitting a support ticket here

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Not applicable

Still nothing.........

Not applicable

What a joke, sent a PM to Support as suggested here, only thing they did was pawn me off to Steam and tell me to bug THEM about how to get this to work.......