cancel
Showing results for 
Search instead for 
Did you mean: 

The Climb 2 taking excruciatingly long to load on the Quest 2

For whatever reason, the Climb 2 is taking ridiculously long to load. Does anyone else have this problem?

7 REPLIES 7

Howie_Doodat
Level 8

This is not my experience. I played it last night with no load issues (I don’t even recall seeing load screens). 

kossesfamily
Level 2

Same for me.  3 different oculus in the house all have the same issue.  Tried rebooting and uninstalling and it made no difference.

mijulan
Level 2

Me too. I updated Climb 2 on my original Quest a few days ago and then it wouldn’t load at all. I tried uninstalling and reinstalling , but same problem. This is unacceptable. 

kikSky
Level 2

i had the same issue few days ago, the game just wont load or takes forever. i found out that the game cant find the server and it hangs. i disabled WIFI from Quest 2 settings and the game was loading normally after that. you lose the leaders board but otherwise the game works fine.

adkram
Level 2

I’m having the same issue. Also uninstalled and reinstalled.  I’ll try turning off WiFi as suggested and see if that works. 

 

That was great - turning off the wifi worked for me. Thanks.

The one drawback is that you can only play in 'casual' mode with no wifi, meaning you are forced to play with no chalk/stamina management which does rather take the challenge and fun out of it.

I hope they patch this soon!



without wifi it works in both modes for me pro and casual, of course it doesn't update the result.