Showing results for 
Search instead for 
Did you mean: 

USB 3.x not working with Quest 2 on new machine. Only USB 2.1 no matter the port.

Not applicable

New machine: Gigabyte z590 UD AC, 11700K (USB 3.2) 6900XT

Old Machine: Gigabyte z390 UD 9700K (USB 3.0) 6900XT

Windows 10-Latest Updates. 


Other USB 3.2 devices work fine and consistently with the new system.


After updating the platform of my rig, USB 3.0 was working intermittently and usually only after a fresh reboot. Once playing, Oc-Link usually crashed about 5-10 mins in.


As of now, it will only connect and function in USB 2.1 mode. Tried all ports, bare bones. Reinstalled windows on a fresh drive, fresh everything with the same results. Tried every version of  Chipset/IO drivers available through the manufacturer.


Old platform still operational to test with. The QUEST 2 connects every time and consistently at USB 3.0.

It's not a reading error as I'm looking at the connection type through alternate software.

It's not the cable, or the Quest's USB C port. I tested two fully functioning cables with the same results on both systems. Tested a second Quest 2 with the same results, on both systems.


I just don't know if it's a driver issue on the mainboard side or something with the Quest device itself?

Newer USB 3.2 Quest 2 compatibility issue versus the older 3.0-3.1 tech?


Again, other USB 3.2 devices work fine with the new system.


Now I have to spend MONEY in a work around attempt by purchasing a C to C cable and go through my GPU's USB C port. I hope it works.


Anyone else have this issue yet?