Showing results for 
Search instead for 
Did you mean: 

Unity 2020 or 2021 - Gaze Pointer - Button Hover not working

Honored Guest

Hi everyone,


I'm facing something very annoying that could not find any answer.

I'm using Unity 2021.1.3 right now (but it has the same behavior with 2020 last version).


To test the capacity of the Oculus Quest 2, I have loaded the Oculus scene called "UI" (from Oculus Integration > VR > Scenes).

I have added a button in the "LightCanvas" next to the other UI elements.

When I use Oculus Link to test it in the headset, everything works well as expected.

But when I build and run it as APK in the headset, the hover color of the button is not showing but the button can still be pushed.


I have found some similar topics on the Internet but none of the answers solved my problem.

I don't understand why a RAW scene from Oculus Integration doesn't work as expected.


Can anybody help on this ?

Thanks for very much





I had the same problem and solved it.
I wrote an article in Japanese, so please translate it.