cancel
Showing results for 
Search instead for 
Did you mean: 

anyone else getting the three dot loading screen

Mykoface
Level 2
In the beginning, my quest was working fine and I was able to navigate apps and game.

Now, when I select home, library, or store, I just get a window that says "Loading store" and three dots that look like its thinking or trying to access a server.

Has anyone else resolved this issue? I'm connected correctly to my wifi and I'm able to browse websites using the browser. I just can't access my apps or games anymore.

Thanks
8 REPLIES 8

el_jergas
Level 3
You mean the three dots stay there forever? In my case I see the three dots when turning on the Quest, for example. And yes, it takes a while to move from the store to the games and vice-versa. But I think that's normal.

Mykoface
Level 2
Yes, the three dots are animated, but stay there forever. I haven't been able to access the home, library, or store since yesterday.

I read a factory reset might help. But, I also heard it messed up someone's gear and they couldn't turn it on again afterwards. I'm looking for other options before resetting.

Mykoface
Level 2
solved. I just ended up doing a factory reset and everything seems to load correctly now.

emabini
Level 2
how do you do a factory reset? I'm having the same problem. 😞

Mykoface
Level 2
  1. Turn off your Oculus Quest.
  2. Hold down the power button and lower volumebutton down until the boot screen loads on your headset.
  3. Use the volume buttons to highlight Factory reset.
  4. Press the power button to select it.

Spuzzum
Level 9
You can also do it from the Oculus app on your phone.

elizabeth_bolas
Level 2
Glad it worked, but if it happens again, you probably just changed your Oculus password. Try logging into the Oculus app on your phone, going to Settings, and the tapping your device name so that it connects. 

WatchLag
Level 2
hey, i know im late, but i found a good solution. do a usb connection test, go to ur vr headset, click oculus link. to do the usb connection test, go to your computer, devices > quest 2 and touch > usb test. when its running, you should see a "device setup, waiting for "(blank)". then, the usb test should fail, and it should open up to oculus link,