Showing results for 
Search instead for 
Did you mean: 

weird charging and link w/cable issue (possible bug?)


So I decided to play the quest 2 after sometime. The type c to type c never gave me any issues until I lost connection and saw that my whole quest 2 UI was updated. Tried disconnecting/reconnecting but the pc never detected it again. 2nd notice, it wasn't charging.  I attempted some things hoping it'd fix it.


1. Tested different cables and tried charging it with its original cable (failed)

2. Held down volume down button and power button to access the boot menu while cable inserted. (began charging)

3. Chose the boot option while in the oculus menu, Oculus booted up (charging stopped, link had no detection)

4. repeated attempt 2, chose factory reset. (was charging in setup, but never charges again after disconnecting and reconnecting, still no link detection)

5. reinstalled oculus app on pc. (no detection)

6. tested type c to type a cable in USB 3.0 port. (charges normally and reconnecting the cable charges it normally, but no link detection)


The last attempt seemed like a "band aid" or temporary fix I guess:


7.went to settings on pc Oculus app >beta > restart Oculus.  Kept type c (PC) to type c (quest 2 headset) connected and rebooted oculus (charges and pc prompt shows up near startup and link is working as it should. However, disconnecting and reconnecting the cable while the oculus is on will start the issue again and you have to keep the cable connected and reboot again) 


 If it is a software/firmware problem, I hope they can patch it up.

Note + I've taken notice the only way I can charge it powered off is using type c to type a with a different charging adapter or power source. Type c to type c does nothing even with its original charging adapter. 


Community Manager
Community Manager

Hey FrostBreacher, thanks for reaching out! We understand how an interruption with Oculus Link and charging can be a real hindrance to your gaming experience. We greatly appreciate that you have already taken several troubleshooting steps towards resolving these issues; and we're glad that you were able to find a temporary workaround to charge your headset!


Since you mentioned that it's been some time since you've used your Quest 2, we recommend double checking to make sure that all of your software and drivers are up to date. You can find detailed instructions for updating your drivers here. Instructions for how to update the Oculus app can be found here. Your Quest 2 should automatically update when it's turned on and connected to Wi-Fi.


Once you've ensured that everything has been updated, if it is still not being detected by your PC, try repairing the Oculus app using the instructions found here.


Completing these steps should get Oculus Link working again and address the charging issue. However, if you're still running into trouble, please collect logs from Oculus Diagnostics and send us a support ticket here. (Instructions for how to collect these logs can be found here.) 



If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Oops, our mistake! You can use the link here to create a support ticket! 🙂

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Update on testing the quest 2:

So, looks like the temporary fix only works when it wants to. I appreciate the help on this and yeah the pc and everything is at its possible latest in updates. The time it was working was when it had its old version (like how the UI looked back when it was released (miss that old UI).  But somehow it seems like it updated while playing a game on link. That is where I took notice after the link stopped during a game and went back on the quest 2 menu is when the whole UI now looked simplified and like a different version. That's when I couldn't charge it or play it on link with a type C to type C anymore. The type C to type A cable charges it anytime, but has no link response. The headset also doesn't seem to work with its original cable or charging adapter anymore.

I've ran the OculusLogGatherer.exe hoping that gathered something on what may be happening.

Currently still searching on the issue. But I'll also setup a ticket.

Sounds good Frost!


Thanks for sticking with us and we're excited to hear from you in our ticket support. We appreciate you and hope the rest of your day goes well.


Reach back out here if you solve the issues so others can see the solution.


If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!



On the support ticket:

Currently uncertain if support is giving tips on something relative to the headset as all the suggestions were related to the PC. And felt I had to repeatedly clarify or point out that the headset would have been the issue since the update happened on the headset itself.  Did a lot of self troubleshooting isolating the problem all lead to the headset since it seems to not want to charge or respond to a power outlet (type c to type c original charger) I understand it's probably routine or part of trouble shooting steps to be thorough probably,  just kind of feels like running in circles but on the wrong track. Still discussing with them about the issue and currently got switched to another support member.

Update: So currently got suggestions on a factory reset and a new update on the oculus but sadly the quest 2 issue remains. it concerns me if the issue is hardware but I'm hoping it can be fixed somehow.



Further personal troubleshooting note:


From my personal attempts it's a gamble, but keeping the headset connected to the pc and then power cycling the headset repeatedly while holding the volume down and power button for a bit, then powering it on normally may have it charging and link detected but maybe like  a 5 - 10% chance of it working. It takes several times. Well, maybe a lot. But have to be active with it,  otherwise the headset seems to sleep or go idle and it'll lose connection automatically and then it's back to square one.  Also disconnecting it with the headset powered on will be back to square one as well.


The only way I've kept my quest 2 from losing battery power is luckily it charges with a type A to Type C cable, but for charging only unfortunately.


comparing the cables, here's what I got:

Type-A to type-C cables,  

  • LED indicator appears yellowish orange, charges only
  • Alternative power adapter, charges
  • Tested on PC and laptop, no device detection on both, Charges.



Type-C to type-C cables

  • still have no response, No LED
  • Alternative Power adapter, No charge
  • Tested on both PC and laptop, no device detection, no charge.



Just found out and I hoped it wouldn't be a Hardware issue on the quest 2, I flipped the Type-C to type-C cable orientation and found out it was working for a second like normal. Charging and connected to the pc but then seconds later it began to reconnect on and off repeatedly on the pc every 2 seconds along with the message "USB device has malfunctioned".  

and now the Device manager say its an unknown device (device descriptor request failed).


In case anyone doesn't know, type-C's can be flipped as designed to avoid reverse polarities. All the pins are rotationally symmetric which means no matter if reversed/flipped, the pins always line up correctly. 


In any case, I guess that's that then. Doing link by cable is likely no longer possible and chances are charging eventually might stop along with this headset once the battery is depleted. had it for maybe almost a year but only felt like I've rarely used it . 


Update on support:

Currently I was asked before to provide what version my headset was, to which I gave them. After I discover a bigger issue leading up to probably a port issue, also tried to confirm if I  still wait 72 hours still after being transferred to a new person. 


Update 10/18/21: 

Support got back and seem to agree on the issue does appear to be hardware, luckily there seems to be availability for replacement  on this one with warranty remaining.  Plan to ship out soon.


I don't think there was any solution here for anyone to repair it themselves unless they're tech savvy.

Otherwise it may have to be replaced, if warranty is still good.