cancel
Showing results for 
Search instead for 
Did you mean: 

15hrs no sleep

david_dawson_34
Level 2
Bought a new pc and new rift s.
Stuck on the connect your headset . Green tick for usb 3 and nothing for the display port.

I have a asus rtx 2070s  I've downloaded latest graphics card. I've clicked on oculus driver to check that also.
I restarted . Rebooted. Changed ports.... at a loss now.
I have 4 usb 3 ports in the back and one hdmi on board port and 1 hdmi and 3 other ports for the quest on the graphics card. Tried all of them. 
When I first tried 15 hours ago when the usb was plugged in the rift would have a blue screen when  plugged into the on board hdmi. Now it doesnt matter where I plug  it doesnt switch on. Just a fast flashing red/orange light between the eye pieces.  Usb3 gets a tick though just the display port does nothing. 
Cant find the serial number??? Also I've put a ticket in allready. Anybody help??
The pc was prebuilt and I'm not exactly up to much on pcs.last time I bought one was 10 years ago. So I'm average tech wise lol
1 REPLY 1

LoneEcho
Level 5
AFAIK you MUST have a displayport connector on your GPU. HDMI- displayport adapters don't work