cancel
Showing results for 
Search instead for 
Did you mean: 

ARK: Survival Evolved crashes going to VR on the QUEST 2

OcuCobaltRod
Level 3
I have an Oculus Quest 2, so a new headset. I just Bought the game ARK: Survival Evolved, so I have the latest version. Through SteamVR I'm trying to run the game VR, but of course it won't start in VR. So I you-tubed video's on how to enable the VR HUD in settings and I follow the simple instructions, but I run into this crash:
------------------------------------------------------------------------------------------------------------------------
Assertion failed: IsInRenderingThread() [File:F:\build\trunkNew\Engine\Plugins\Runtime\OculusRift\Source\OculusRift\Private\OculusRiftRender.cpp] [Line: 749]
VERSION: 318.9
KERNELBASE.dll!UnknownFunction (0x00007ffb78a43b29) + 0 bytes [UnknownFile:0]
ShooterGame.exe!FOutputDevice::Logf__VA() (0x00007ff627480a88) + 159 bytes
ShooterGame.exe!FDebug::AssertFailed() (0x00007ff62746dc88) + 117 bytes
ShooterGame.exe!OculusRift::FCustomPresent::Present() (0x00007ff628c27619) + 0 bytes
ShooterGame.exe!FD3D11Viewport::PresentChecked() (0x00007ff627826f66) + 11 bytes
ShooterGame.exe!FD3D11DynamicRHI::RHIEndDrawingViewport() (0x00007ff62782f69f) + 0 bytes
ShooterGame.exe!FRHICommandListExecutor::ExecuteInner_DoExecute() (0x00007ff627885388) + 0 bytes
ShooterGame.exe!TGraphTask<FExecuteRHIThreadTask>::ExecuteTask() (0x00007ff627885674) + 32 bytes
ShooterGame.exe!FNamedTaskThread::ProcessTasksNamedThread() (0x00007ff6274116ec) + 0 bytes
ShooterGame.exe!FNamedTaskThread::ProcessTasksUntilQuit() (0x00007ff6274118cd) + 0 bytes
ShooterGame.exe!FRHIThread::Run() (0x00007ff6278955d6) + 0 bytes
ShooterGame.exe!FRunnableThreadWin::Run() (0x00007ff6274c2c96) + 0 bytes
ShooterGame.exe!FRunnableThreadWin::GuardedRun() (0x00007ff6274be038) + 8 bytes
KERNEL32.DLL!UnknownFunction (0x00007ffb79627c24) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ffb7afad4d1) + 0 bytes [UnknownFile:0]
ntdll.dll!UnknownFunction (0x00007ffb7afad4d1) + 0 bytes [UnknownFile:0]
Crash in runnable thread RHIThread
-------------------------------------------------------------------------------------------------------------------------
I've spend way too much time trying to get this game to run in VR. I have not been able to resolve this issue with multiple attempts in multiple ways, too many to list here. So I guess my question is "Are there other Quest 2 owners out there running into this issue?" or "Are there any Quest 2 owners able to play ARK: Survival Evolved in VR?, I mean, if it doesn't work in VR, it doesn't work in VR and I'll return the game. Thanks for any help or responses! ~ Rodney
2 REPLIES 2

Anonymous
Not applicable
I thought the VR was disabled in that one when ARK PARK was released which is VR only ?

Tadin
Level 7
Yeah, i dont think its worked for a couple of years.