cancel
Showing results for 
Search instead for 
Did you mean: 

DisplayPort connection not detected

Percevan
Level 3
I got a problem with the Rift S. When the MiniDisplayPort adapter is plugged (I have to use it because I don't have a DisplayPort), my rift S connect for 2 seconds and then disconnect. I've tried plug/unplug, try on another MiniDisplayPort but nothing changed. I've updated all my drivers. I've also tried repairing Oculus, but nothing worked for me. Someone have a idea ?
I have a desktop machine and a GTX 970.
24 REPLIES 24

zaptoman
Level 3
What lights are on on the Rift S when you have it all plugged in?

Percevan
Level 3
When I have the USB plugged, only the white led. But when i plug the MiniDisplayPort, the blue led lights for 2 seconds and turn off.

Percevan
Level 3
I don't know if that can be usefull, but here's my logs. Lots of "USB connection failed" but i don't understand, my USB connection work because my computer detect my Rift S when i plug it...

zaptoman
Level 3
In the past I've seen that the Rift S will claim Display Port is not connected when in fact the headset just seems not to be receiving enough power via USB. Try unplugging anything else from your USB 3.0 ports, see if that makes a difference.

Framer1
Level 2
Same Problem here. On Monday i installed the Rift S. It was possible to come to the controller settings. But Insite the Rift the screen is black. After the new Firmware update i got a new problem. The Display cable is showing as " not connectet". Today i got a new Rift S, but there it is the same Problem. It must be an issue with the new Firmware update... I can not install the Rift S. The Display Port light stopt and the blue Light in Front of the Rift stoped working. The Support can't help. 

Percevan
Level 3

zaptoman said:

In the past I've seen that the Rift S will claim Display Port is not connected when in fact the headset just seems not to be receiving enough power via USB. Try unplugging anything else from your USB 3.0 ports, see if that makes a difference.


Tried that, but same problem.

tempemonkey
Level 3
This is starting to get pretty old now... I jumped through a dozen hoops, mailed back my headset and got a new one... Same problem persists as described on this thread... Pretty sure it is an Oculus problem seeing that I ran Oculus CV on the exact same setup for years with no problems... They are virtually the same product physically.

Zemongar
Level 2
I just had this problem, I was just about to call tech support when I tried one last thing, uninstalling the app and deleting every oculus related file before downloading a new installer and re-installing. This will lose all your settings, not sure how my saves turned out, but it registered my DisplayPort connection and is working.

SteveH160855
Level 2
Same problem as the original poster. New install, hangs at the Displayport connection. I've tried all of the above with no effect. Any other suggestions, I really don't want to return it to the store without ever seeing what it can do.