Showing results for 
Search instead for 
Did you mean: 

I have an "extra" right touch controller listed as off with low battery and I can't remove it.

The extra controller is a phantom... Any Ideas? I unplugged the Rift and plugged it back in. Resynced the controllers. In oculus under devices I have an extra right touch and I can't remove it, says It will remove it from the list however it does not. And I keep getting a critical warning in my headset that the controller is low battery....  It's annoying.

Since I returned my Rift S, uninstalled it (and its controllers) in the app/devices, and went back to my Rift cv1 I still get a right Rift S controller showing up, even if I try to delete it from the list.  At least it does not seem to actually cause any harm though so now I just ignore it.
i9 13900K water cooled, RTX4090, Z790 MB w/wifi6e, 32Gb 6400 ram, 2x2TB SSD, 1000W PSU, Win 11, QPro, Q3, w/Link and Air Link, Vive Pro1 with Etsy lens mod and Index Controllers

I have the same issue, my devices list has 3 right touch controllers listed now that I can get rid of and this is 4 hours into owning the Rift S. 

Honored Guest
I have the same issue, the way I fixed this is delete the whole folder Oculus which under C:\Users\your user name\AppData\Local and restart Oculus. BTW: Don't forget to close Oculus software in task manager before your started
I hope this will help you guys 🙂

Not applicable
No need to nuke your entire settings to fix this:

Just in case you don't want to follow random links:
  • Close the Oculus app

  • Stop the service "OVRService"

  • Go to "%LOCALAPPDATA%\Oculus\"

  • Make a backup of the file "DeviceCache.json"

  • Open the file with a text editor capable of formatting JSON in a more human readable way (I used "VS Code" with the "Prettify JSON" extension).

  • Remove the the device blocks for the broken entries and save

  • Start OVRService again

  • Start Oculus app again

  • Presto no more broken entries. ?

I fixed the problem by simplifying SuperFlue's method a bit so you don't have to edit the .json-file:

  • Close the Oculus app

  • Stop the service "OVRService" (I use OculusTrayTool for that)

  • Go to "%LOCALAPPDATA%\Oculus\" (path usually is C:\Users\YOUR_USERNAME\AppData\Local\Oculus\)

  • Make a backup of the file "DeviceCache.json" (just in case...)

  • Delete the file "DeviceCache.json"

  • Start OVRService again

  • Start Oculus app again and setup your Rift S and Touch controllers

That annoying and persistent mysterious right Touch controller is gone!

Superflue method works for me.

Then phantom controllers came back.

I uninstalled Oculus completely, reinstalled everything again.

Phantom controllers came back with a vengeance: DeviceCache.json was EMPTY! 

The I just did what Lanzoracer said, resolved the issue! 

Let's see how long until phantom controllers come back. 

Excite to pay $400 to be a beta tester for Facebook! Yay! \o/

Honored Guest
yeah, so what worked for me was to quit out of oculus entirely using task manager,  then I deleted C:\Users\[myUserName]\AppData\Local\Oculus\DeviceCache.json  I had to go through the boring setup video, but I was back in business.  I'm probably going to return the thing though, it seems real buggy, can't seem to play any games at all without them crashing.  Also the headgear is super uncomfortable.  

If you don't want to have to run the setup again, you can use my program at
It removes the extra controllers from the cache file for you, no need to edit json manually or delete the cache.

Author: Oculus Monitor,  Auto Oculus Touch,  Forum Dark Mode, Phantom Touch Remover,  X-Plane Fixer
Hardware: Threadripper 1950x, MSI Gaming Trio 2080TI, Asrock X399 Taich
Headsets: Wrap 1200VR, DK1, DK2, CV1, Rift-S, GearVR, Go, Quest, Quest 2, Reverb G2

Honored Guest
Had the same problem with phantom Right controllers in the list, had about six of them. Could not remove them.

So Just followed Lonzoracer's instructions and it seems to have done the trick, after restarting Occulus and setup the Rift S again, I now only have one set of controllers in the list, thanks Lonzoracer.

I have had this issue for a while. I have tried everything listed on this page - kojacks program, deleting the .json file altogether. Nothing has worked as each time the controller reappears with a low battery warning requiring me to go through the stupid setup again to repair my controllers.

Hey Oculus... why don't you solve this issue already!?