Showing results for 
Search instead for 
Did you mean: 

No light, No display, Not connecting


I have had my Rift S Headset for almost 3 years, and it has had problems before, but not like this.

I tried plugging it in after a few months not being on it due to college work, but it doesn't display anything. The first time I plugged it in after a while, the lights displayed as normal and it connected fully, but still no display, now, nothings showing up. No lights on the headset, not check marks at the setup stage (to show display port wire and usb wire are plugged in) and nothing displays on the screen itself. I haven't damaged the headset significantly, only the occasional bump as I set it down sometimes, but nothing too bad to cause this damage.

I have all the necessary parts to run vr as I have been using it before

I have tried unplugging it, leaving it, then replugging it. No change.

I have tried seeing if I needed to update the drivers but the oculus drivers program wouldn't open.

I have enabled the public test channel, restarted oculus and tried repairing it but all of it still didn't change anything.


I really want to avoid buying a new wire, if this is a problem I can solve without replacing anything, id rather try to fix it or get a different vr as I'd prefer a wireless one anyway.

If you know how to fix this, please tell me asap.



*ignore this comment, I forgot how to delete replies ^^'