Showing results for 
Search instead for 
Did you mean: 

Rift S Black Screen FIX (only for me?)

Not applicable
Got a fix for black screen! Just put the Rift in Display Port 1 of your graphic card! There it is working since an hour, no problems! On DP 1 or 2 it wasnt working, strange. (Newest nvidea driver, older Win 10 Version) Hope that will help you guys..

I have all ports used and none worked. In another thread we are two with the same problems and same mainboard.

Not applicable

dburne said:

@dburne what graphic card and mainboard you use?

EVGA 2080 Ti FTW3 Ultra.
EVGA Z390 Dark MB.

Think I may have solved the issue. After investigating found I had the headset USB plugged into an AsMedia 3.1 Gen2 port. I moved it to an Intel USB 3.1 Gen 1 port this afternoon.
So far so good, been working all afternoon closing Home and re-opening it.
Keeping fingers crossed that this too is not just an anomaly!

I thought it would be that even though there's many pointing to moving the DP Port. Seems it is the head sensor via a compatible USB HUB Driver. Another user said he got his fixed by moving away from the ASMedia Driver. Check if there's any other available Driver in HUBs and eXtensibles by a Manual Selection.

In the meantime until Tuesday I get RIFT S, I ordered the FebSmart 4 port USB3.0 PCIe Card as I could use the extras anyways. Must be a USB3.0 as recommended by Oculus rather than the 3.1 it seems.

Will give this a shot, thx. My other USB 3.0 ports are on AMD eXtensibles. I have 2 with "VR Ready" and another 2 without this. The ASMedia is only for USB 3.1 and Type C.

Have changed to a driver from MS for the ASMedia - after a smoke I will give it a try ::smile:

Update: First time today it works. Only on the USB 3.1 ASMedia with the MS drivers.
Update: A little bit of Lucky's Tale and 4 Songs Beat Saver done. Thank you @MAC_MAN86, this i a bit of light in the darkness^^