Showing results for 
Search instead for 
Did you mean: 

Rift s problem solved

Honored Guest
Hello everyone,

I was able to solve my problem with the Rift S. 
I have spent countless hours on it. I've really done everything that is written in all the forums on the www.
For me the solution was a mixture of 2 solutions that are widely used. 

My motherboard is the ASRock Extreme 3 Gen 3 (Z68).
CPU I7 3770k
Graphics GTX 1070 Gainward Phoenix GS. 

1 solution: 
Inateck USB 3.0 PCIE card
The USB 3.0 slots on the motherboard are to old.
He recognized the Rift S (With the Inateck). I could also play but unfortunately he crashed often. Here I had the problem with the snow and static bla bla bla...
I connected the Inateck with the power supply (Super Flower Golden Green 80+ Gold 550w)! 

I tried everything really everything and then I thought about a HUB.
But why a hub? My Inateck is already connected to the power supply. 

2 solution:
Now I read something here in the Forum. Someone has connected the Oculus to the monitor USB 3.0.
I myself own an ASUS PG278QR with USB 3.0 connectors. So I tested it directly. 
I have connected the monitor to the USB 3.0 of the Inateck card.
!!!! In fact it did not work with the USB 3.0 from the motherboard !!!!
And now it works without problems!  No crash. I can play a whole day without any problems!
Probably a HUB (with external power) would work too. The Rift S get power from the monitor. 

So short:
Inateck card + USB HUB with external power was my solution.

Maybe I can help somebody with it.

Just... WTF? 

Honored Guest
Which Rift S Problem?

Honored Guest
Doesnt find USB Connection, USB Connection Lost, DiplayPort Connection Lost, Static/Snow, Tracking lost...