cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to install OculusSetup - Fails to install Oculus Driver

simondarksidej
Level 4
I started getting a warning in the Oculus client after the latest update, stating a Driver update was needed (I suspect the Oculus Service), however, repeated attempts to run the update failed or did nothing.

So I decided to do a clean re-install, only to find I can no longer even install the Oculus client for that very same reason.

The Oculus Setup log just reports "Driver failed with error code -1"

Extracting and running the Driver-Setup.exe separately (version 1.43.0.000002) seems to indicate it was unable to install the Oculus Service (log attached)
(and yes, I've tried with and without AV enabled)

Please help as I'm trying to build a Rift title and now I cannot run a rift to test

PC Details as follows:

* Windows 10 build 1903 (19025.1, insider preview)
* GE Force 1080 Ti
* Original Rift

I usually install on my second drive but have even tried on my original with no success

3 REPLIES 3

Adimote
Level 2
I'm also getting this issue (oculus-driver.exe exited with code -1).
Logs look exactly the same as whats posted above.

- Windows 10 build 1809 (17763.864)
- RTX 2070 Super
- Only a Quest has been plugged in.
- No special user settings on windows AFAICT, just a single profile with admin and default settings.

Also attempted re-downloading & restarting

Adimote
Level 2
Hi, I seem to have solved this on my end by removing the manually-installed adb drivers (clicking 'uninstall' in the device manager on the ADB device and the XRSP device)

simondarksidej
Level 4
Latest 19033.1 build has resolved issues.  You will still however have to reinstall the Oculus client and your Graphics drivers to clear any residual problems