cancel
Showing results for 
Search instead for 
Did you mean: 

Oculus Quest 2 Windows 11 Performance. can never hit maximum FPS with link cable.

Gifted83
Level 4

I decided to give windows 11 a go and everything on my PC is working flawlessly apart from one big one... Oculus Link performance. Before I go back to windows 10 I wonder if anyone has figured this out already.

 

Oculus software works fine and the Quest 2 link connects, but it can never hit the required fps settings no matter what they are. So if I have link set to 90hz, then in game it will be about 82-85fps and stuttering, it never hits 90fps even though the game says its locked at 90 on my monitors no problem, and I have loads of headroom in performance monitor (I have a 5900x and RTX 3090!) - If i use the 120hz option then i will get about 105fps but never 120. Even if i choose 72hz ill get about 65fps. super annoying.

 

I went onto the beta channel on the software and got the latest updates but still no luck.

 

I dont mind going back to windows 10 and i get windows 11 might not be ready yet, but literally EVERYTHING else on my pc works fine, only the vr performance, so its a shame. Any ideas of things to try before I reinstall windows 10?

453 REPLIES 453

zektulu
Level 3

for update,

 

Tonight I received a new version of oculus software (34.0.0.53.185) but I still get frame drop, I will wait for Ryzen patch and see if it's better

JohnnyStormy
Level 2

Nope, I used the PTC to download the latest oculus beta build but this didnt help either. Still need to use console visibility 

I tried them both. Didnt help. But let me know if you have different results. good luck

Is there an ETA? The debug console hack works - hopefully you have seen those posts and sent them to the devs as that will help them debug.

tonight, I have try with the last KB (the one who fix the ryzen performance) but even with the debug console tips it's working only few minutes, after I've got again frame dropped (on lone echo 2)

this worked for me if the console window was tabbed in...crazy what things manage to fix oculus.

Yea my guess is the issue is unrelated to processor chipset. I think there are some kernel level issues with the OVR Server and Windows 11. (I'm on an Intel 7700K and am also having this exact same issue)

ok so I think I have manage this (specially for lone echo) : I have to disable my graphic cards overclocking.

I can play more than 5 minutes without experience frame dropped ! Cross finger I will try to make a long session later in this week-end ! 

I forgot : with the debug console open tips .....

so I do not understand anymore,

 

tonight I try again to play and I experience a lot of frame dropped again..... 

 

It's very annoying problem ! Hope the oculus will update the software soon as possible !