Showing results for 
Search instead for 
Did you mean: 

Bug Report - Hand Tracking is being Shaky/Laggy (Reproduced on 2 devices)


Hi, after going through the forums, back and forth between Meta Support, they couldn't help me, so I am going to put all the information together here.

Hand Tracking seems to work but it's incredibly shaky when staying still. I managed to reproduce this on a Quest Pro and Quest 2 on Link and Standalone. This seems to be exclusive to OpenXR apps, it doesn't happen in the Home environment nor Apps such as First Hand Experience app or at least it's not as noticeable. 


I managed to reproduce this in the new Aura sample app that got released on App Lab on Standalone. As well as other two barebones OpenXR apps via Link.


Here's two videos showing the issue: (I made sure to be in lit environment, so it's not bad lighting)

Video #1:

Video #2:


Version v49 ( on Standalone (Quest Pro)

I also tried both the latest PTC version ( and the stable version ( of Oculus PC software on Link, if that matters.


My first forums post about this issue: PTC v50 Oculus Link issue - Hand Tracking is shaki... - Meta Community Forums - 1030901 (




I'm Currently having the same issue hand tracking via OpenXR on PC is essentially unusable because of how shaky it is however it works perfectly fine on the device itself. I tried disabling passthrough, eyetracking, and facial expression over oculus link thinking it was maybe a bandwidth limitation but the issue is still present.


I'm curious if this maybe has to do with what type of link cable is being used on PC but i see your having the issue on standalone apps as well, is that correct?

I use the official Link cable, also happens on Airlink but that shouldn't matter since it also happens on Standalone.

Ahhh dammit was hoping maybe that was the culprit It appears to be specific to OpenXR applications then regardless if they run on the headset or PCVR then, as handtracking is  otherwise fine in PokerstarsVR and in the the Quest Home World (or whatever its called)

Honored Guest

Facing the same issue😭

And if there any update, please help! Thanks!!!

Honored Guest

Is the time you are passing into XrHandJointsLocateInfoEXT the int64_t (XrTime) predicted frame display time in nanoseconds? Make sure that if you have type conversions you are handling them properly. A mistake here can result in shaky hands.


I'm also having the same issue. It was working great when working on the pre2 release of xrhands, so I tried rolling back to that and it's still terrible. My hands show up for just a few frames every few seconds. looks like openXR is thinking that they go untracked, tracked, untracked very frequently. The more I looked into it the more it feels like it might be an issue with a meta update?

Update to this, everything seems to be working great after a headset and computer reboot. I noticed my hands being a little choppy in headset, and after a full restart it everything is seems to be okay again. Meaning it's not the openXR hands package, it is that the hand tracking on my quest pro sometimes gets into a bad state.