Showing results for 
Search instead for 
Did you mean: 

UE4 OpenXR capacitive touch input issues (bug report)

Rising Star

Last night I tried using OVRPlugin OpenXR and Native OpenXR as XR API in my project. Turned out that capacitive touch events on Oculus Touch controllers don't work with OpenXR 😞

I am using Oculus fork of UE 4.27.2 with 1.70 integration (the latest available from Oculus for UE4 devs). Here is the setup:
































When touching thumbstick, nothing happens. When moving finger toward trigger and then touching it, value always stays at 0.0


Rising Star

So, I tried AnyKey node to see what I get:


Comparing to the official docs: we find that ...


Oculus Touch (R/L) Thumbstick CapTouch is called Oculus Touch (R/L) Thumbstick Touch; Oculus Touch (R/L) Thumb Up CapTouch doesn't work (or doesn't exist); Oculus Touch (R/L) Trigger CapTouch doesn't work (or doesn't exist); Oculus Touch (R/L) Pointing CapTouch doesn't work (or doesn't exist); MotionController (L) FaceButton1 (Button X) doesn't work (pressing/releasing) - instead only Oculus Touch (L) X Button CapTouch (which is actually now called Oculus Touch (L) X Touch) works.


And on top of that when you are in the Project Settings > Input > you can find things like Oculus Touch (R/L) Thumb Rest CapTouch, which I think is referring to Rift CV1 touch controller's thumb resting spot that doesn't exist on Quest 2 controllers (or does it?).

Using UE Launcher build 5.0.1

The Touch inputs (X/Y/A/B, Trigger, Thumbstick Touch) all trigger.

I know you're not using that build, but knowing it works as expected might provide insight into your issue.

What XR API do you use in UE5 ?

Also, if you read my post carefully you will see that while they also all trigger in 4.27.2 (except X, which is a known bug), they don't function as they should (per Oculus input docs).


It's hard to read the block of text.

I'm using vanilla OpenXR plugin, not using OculusVR plugin (just Oculus Subsystem for now).


Screenshot of touch input bindings.

Screenshot 2022-04-25 140122.png

Honored Guest

Hey motorsep (its imagine 👋) ... I confirm I have the same issues in launcher version ue4.27.2

None of the sensor buttons are working with Quest2 Controllers, Thumb Capacitive nor Thumb Up Capacitive, nor the trigger cap, pointing finger, nothing capacitive works using normal input axis mappings in project settings... if print strings it just stays at 0. Seems like a BUG

this one does work though