Showing results for 
Search instead for 
Did you mean: 

Golf+ stuck on loading screen.

Honored Guest

Anybody help with a suggestion how I can get the game to actually load instead of just saying it's loading and nothing happened 


Honored Guest

Same issue here. Worked yesterday. All other games work. Quest 2. Reboot didn't work. I don't want to reinstall as that is not a legit fix.

Hey @NthHour. We understand how Golf+ not loading properly can be troubling when just you just want to golf within your own home. We know how fun that game is and not worry we'll do all that we can to get this right for you. 


We see that you already tried rebooting the headset and that didn't help. We know you don't want to uninstall and reinstall the game, but that could just be the step needed to fix this. Can you please try that for us and get back to us with the results? 


We look forward to hearing from you with a update! 

Hey @NthHour. We are just reaching back out to see if you're still having issues with Golf+ not launching. We want to do all that we can to fix this for you. We look forward to hearing back from you soon. 

Honored Guest

Hello @NthHour, I'm also having the same problem with GOLF+ getting stuck on the loading screen. I have uninstalled and reinstalled multiple times now. I reached out to the GOLF+ developers via their DISCORD channel and they informed me that it is a problem associated with some of the files missing from the store during the downloading process and that is the reason why the game won't boot past the loading screen at startup. They said it is something that Meta needs to fix and that they have informed the Meta Store.